8

Before, I could hit Control-R in GNOME Terminal to enter Bash's (reverse-i-search) mode.

However, this stopped working, the cursor just flashes without doing anything. This also affects remote and container shells (where it was working before).

Although I've noticed, it works when I'm pressing: Control-Shift-R.

I'm using GNU bash v4.4.19 on GNOME Terminal v3.30.1. I'm not sure if this is some new feature of Ubuntu Cosmic, or something else.

It seems, this also affects web-browsers, where I've to press Control-Shift-R to refresh the page, and Control-R doesn't take any effect (Chrome and Opera).

My keyboard works fine, I don't have Caps Lock enabled, and I'm not using any custom programs to modify the default shortcuts and I've never changed any. The issue is reproducible all the time, I've tried this already over hundred of times, the same effect.

How do I change the shortcut back to previous default combination (Control-R)?


What I've tried:

  • Reset All Keyboard Shortcuts to default in Ubuntu Settings.

Here are few details:

$ bind -p | grep 'search-history'
"\C-s": forward-search-history
# non-incremental-forward-search-history (not bound)
# non-incremental-forward-search-history-again (not bound)
# non-incremental-reverse-search-history (not bound)
# non-incremental-reverse-search-history-again (not bound)
"\C-r": reverse-search-history

I've checked, and I don't override the above bindings in my dotfiles:

$ grep -r reverse-search-history ~/.bash*
(nothing)
2
  • 1
    The output of bind -p | grep 'search-history' might be helpful – steeldriver May 12 '19 at 22:52
  • @steeldriver I've updated the answer. – kenorb May 12 '19 at 22:54
24

I had this problem and realised I had SimpleScreenRecorder running which was capturing the CTRL+R hotkey. Hope this helps any googlers!

5
  • 7
    Holy sXXt man, so it's not just my fail ;) – benelgiac Nov 27 '19 at 16:16
  • 3
    lmao thank you very much. I felt like a moron googling "control r search stopped working" – Jaxkr Feb 18 '20 at 8:55
  • 1
    I am on Windows 10, and recently installed TinyTake. As a web dev, I've been having an awful time trying to understand why my refresh shortcut didn't work anymore. Not even PowerShell's reverse-i-search, everything needed to be ctrl+shift+r. It didn't even occur to me that having TinyTake running in the background would DO this to my basic keyboard shortcuts. But sure enough, exiting the app, restored my regular keyboard shortcuts. CRAZY. Thanks for the answer! – RedactedProfile Feb 26 '20 at 18:23
  • 2
    omfg you are a hero :) – Rajan Verma - Aarvy Jul 26 '20 at 16:55
  • 1
    Thanks so much! In my case it was app 'TinyTake by MangoApps' running in the background. Im on Win10. – BlueDev Feb 18 at 18:49
0

If someone is experiencing the same problem, check if you have fzf installed, and make sure to upgrade it to the latest version.

It binds the Control+R to use the fuzzy finder:

CTRL-R - Paste the selected command from history onto the command-line

  • If you want to see the commands in chronological order, press CTRL-R again which toggles sorting by relevance.

I was using fzf version 0.18.0 with Ubuntu 18.04.4 and the reverse search was broken. Upgrading fzf to the latest version available (0.21.1) and executing the install script again solved for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.