4

For a few days now, my Ubuntu Software Center won't start. Ubuntu One also won't connect (not sure if that's related).

When I try launching Software Center from Dash, nothing happens. If I try running 'software-center' from terminal, I get this error message:

2012-03-19 10:26:43,316 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
Traceback (most recent call last):
  File "/usr/bin/software-center", line 149, in <module>
    from softwarecenter.ui.gtk3.app import SoftwareCenterAppGtk3
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 82, in <module>
    from softwarecenter.ui.gtk3.panes.installedpane import InstalledPane
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 43, in <module>
    from softwarecenter.backend.oneconfhandler import get_oneconf_handler
  File "/usr/share/software-center/softwarecenter/backend/oneconfhandler.py", line 25, in <module>
    from softwarecenter.backend.restfulclient import get_ubuntu_sso_backend
  File "/usr/share/software-center/softwarecenter/backend/restfulclient.py", line 36, in <module>
    from lazr.restfulclient.resource import ServiceRoot
ImportError: No module named restfulclient.resource

I'm running Ubuntu 11.10 AMD64

EDIT:

It started happening after I install all the dependencies needed to setup an environment to work on the Ubuntu Summit website. I'm assuming something I installed must not have played nice with the rest of my system.

  • 3
    file bug report askubuntu.com/questions/5121/how-do-i-report-a-bug – Tachyons Mar 19 '12 at 14:36
  • Please, could you post the output of dpkg -S /usr/share/software-center/softwarecenter/backend/restfulclient.py? I cannot find that file in the Ubuntu archives. – Andrea Corbellini Mar 19 '12 at 14:55
  • @AndreaCorbellini This is what I get: software-center: /usr/share/software-center/softwarecenter/backend/restfulclient.py – FelicianoTech Mar 19 '12 at 22:31
  • what version of Ubuntu? What version of Software Center? – cprofitt Mar 20 '12 at 2:18
  • @cprofitt Ubuntu 11.10. Software Center, umm whichever is suppose to be in 11.10 I guess. – FelicianoTech Mar 27 '12 at 13:48
1

Try running the following command to reinstall software center.

sudo apt-get install --reinstall software-center

If this does not work try:

sudo apt-get install python-simplejson

| improve this answer | |
  • No go. Wasn't fixed :/ – FelicianoTech Mar 19 '12 at 22:31
  • Python Simplejson is already installed as well. Not sure what else to do. Neither this nor Ubuntu One works anymore, even after I followed a few guides on restoring them. I might just wait till my 12.04 fresh install. – FelicianoTech Mar 27 '12 at 13:51
1

Please update your system in a terminal with sudo apt-get update && sudo apt-get upgrade.

If you get any faults there link those in your question, if this solves your issue then flag this to the moderators, if nothing happened drop a comment.

| improve this answer | |
  • I had the same issue, it was resolved with a updated system and I reinstalled the USC. – Alvar Mar 24 '12 at 12:10
  • There are no problems with updating. I followed suggestions in all the answers above to no avail as well. – FelicianoTech Apr 4 '12 at 13:30
  • You should file a bug for this then. You can do so by opening a terminal and typing ubuntu-bug software-center. – Bruno Pereira Apr 4 '12 at 13:38
0

No clue if this will help you, but the same thing happened to me after messing with python-pip, python-setuptools and python-virtualenv.

$ sudo apt-get install --reinstall python-pkg-resources

fixed it for me.

Actually looking at your traceback says it all. Run this...

$ sudo apt-get install --reinstall python-lazr.restfulclient

This is a dependency of software-center. If you look up software-center online or in synaptic, you'll see it's required. But your traceback is saying it can't find that module.

| improve this answer | |
  • I got excited when I saw your answer because it looks like that would work but sadly it didn't. 22 days till 12.04. It better work with a fresh install of Precise. – FelicianoTech Apr 4 '12 at 13:29
  • 1
    have you tried $sudo apt-get install synaptic to see if there are any broken dependencies? Synaptic is a very useful gui for installing and managing packages. You might be fine with Synaptic until Precise comes out. – Mark Mikofski Apr 6 '12 at 7:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.