11

I've started seeing a livepatch warning in my system tray.

System tray icons.

Clicking it takes me the the livepatch client where I see this error message:

Canonical Livepatch has experienced an internal error. Please refer to https://wiki.ubuntu.com/Kernel/Livepatch#CommonIssues for further information.

Despite the URL, there isn't a #CommonIssues section on the page: https://wiki.ubuntu.com/Kernel/Livepatch#CommonIssues

Any ideas how I can fix this?

Ubuntu 18.04.2 LTS
4.15.0-34-generic

  • 3
    Run sudo apt install gtk3-nocsd and then export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0. Also, canonical-livepatch refresh require sudo privileges – Kulfy May 12 '19 at 12:04
12

In terminal i just fire this command and it worked, try this

sudo canonical-livepatch refresh

In Detail you can read here

  1. Canonical Livepatch informs about internal error - what to do?
  2. https://ubuntuforums.org/showthread.php?t=2420465
| improve this answer | |
  • 1
    I started to receive error after manual update and restart of computer (restart was required even before livepatch was activated on the machine). This one helped. Thx, – Honza P. Feb 11 at 20:28
5

This forum thread describes the same issue and says the solution is to use a new livepatch token:

  1. disable the livepatch service sudo canonical-livepatch disable

  2. get a new token from https://auth.livepatch.canonical.com/

  3. enable the service with your new token sudo canonical-livepatch enable <your token>

| improve this answer | |
  • I started getting this after cloning to a new SSD. Getting a new token fixed it. – aucuparia Jan 5 at 8:15
-1
  1. head to the Livepatch page and create an account. You can license up to 3 servers for free, so there is no cost unless you plan to mass deploy Livepatch. https://www.ubuntu.com/server/livepatch

  2. Once you've created an account it's as simple as running the following commands:

    sudo snap install canonical-livepatch  
    sudo canonical-livepatch enable $your_token  
    
| improve this answer | |
  • Welcome to Ask Ubuntu! According to the question, OP had livepatch set up already but got a problem with it. Your answer is not even trying to solve this problem. – Melebius Jun 18 '19 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.