1

I tried to upgrade to Ubuntu 19.04 through the software-update and it kinda worked well this time, except that it failed that a menu is not installed properly and issue with that and it'll start rollback to the old version.

I thought it's going to be okay and it'll rollback and nothing happened for an hour, so I restarted the system. Now I am in Ubuntu 19 and all the applications work fine but the problem is I can't access the dash menu (start menu).

Every time I try to open dash or press the window key, the desktop environment crashes and pushes me to the lock screen. I am not entirely sure what's missing here and don't know where to look up for the cause.

Let me know if you need me too look up for the logs somewhere and paste it here.

7
  • 1
    There is no Ubuntu 19 with standard Ubuntu releases being yy.mm in format; Ubuntu Core is an exception but that uses yy format but hasn't come out this year. Thus I'm wondering how you did your upgrade? Did you use an official tested tool? (eg. do-release-upgrade or something else). If it didn't complete; I'd login to a terminal, and sudo apt dist-upgrade to see if it'll continue & complete). If you didn't upgrade from 18.10; you're outside of tested & supported upgrade paths anyway.
    – guiverc
    May 12, 2019 at 5:20
  • I was upgrading from Ubuntu 18.10 using do-release-upgrade. The current version shows as 19.04. If I try sudo apt dist-upgrade it shows 0 upgraded, 0 newly installed message.
    – Vignesh
    May 12, 2019 at 5:32
  • 1
    In your position: I would sudo apt update (and look at the output as it scrolls to ensure 'cosmic' [18.10] lines are gone, with 'dingo' [19.04] lines having replaced them), then sudo apt dist-upgrade again expecting 0 to upgrade (but just to be safe). The next likely cause that comes to mind is if you've added other gnome extensions (18.10 or before) that aren't compatible with the newer gnome release; as if these cause a 'crash', gnome-shell will exit & you're returned to login screen.
    – guiverc
    May 12, 2019 at 5:53
  • I have gnome-tweaks and bunch of other extensions installed before, maybe I'll try to remove them and see if that helps. Thanks for your help.
    – Vignesh
    May 12, 2019 at 5:56
  • 1
    Just did the upgrade to 19.04 from 18.10... gnome is fucking bugged as hell. It was running perfectly stable before and now I'm here with a pile of shit which crashes every 30 mins. Fuck off ubuntu.
    – Eugene
    Jul 6, 2019 at 13:57

1 Answer 1

2

I had the same problem.

Started gnome-tweaks from a terminal and disabled extensions.

Looks like Ubuntu appindicators caused the problem.

1
  • It didn't solve the problem for me, I just erased and reinstalled 19. It was easier that way than trying to mess with it. It saved a lot of time. :p
    – Vignesh
    May 14, 2019 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.