0

I'm running Ubuntu 19.04 Desktop, and I would like to install Vulkan. I already installed the Nvidia drivers from the Software and Updates app, but when I try to install Vulkan from the command line using sudo apt install vulkan vulkan-utils, I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package vulkan

I checked to make sure I have the PPA, and I do. Looking at the PPA's website, though, it shows Vulkan for 18.04 and 18.10, but not 19.04. How would I go about installing Vulkan on my 19.04 system? Assuming it's even possible, that is.

EDIT: The results of running sudo ubuntu-drivers devices are the following:

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001B82sv00003842sd00005671bc03sc00i00
vendor   : NVIDIA Corporation
model    : GP104 [GeForce GTX 1070 Ti]
driver   : nvidia-driver-415 - third-party free
driver   : nvidia-driver-418 - distro non-free
driver   : nvidia-driver-396 - third-party free
driver   : nvidia-driver-430 - third-party free recommended
driver   : nvidia-driver-390 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

When I tried to run sudo apt-add-repository ppa:canonical-x/vulkan I got this error:

Cannot add PPA: 'ppa:~canonical-x/ubuntu/vulkan'.
The team named '~canonical-x' has no PPA named 'ubuntu/vulkan'
Please choose from the following available PPAs:
 * 'testing':  Testing PPA
 * 'x-staging':  Canonical X Staging

And running lspci -knn | grep -A3 -i -E "(VGA|3D)" gave me the following:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104 [GeForce GTX 1070 Ti] [10de:1b82] (rev a1)
    Subsystem: eVga.com. Corp. GP104 [GeForce GTX 1070 Ti] [3842:5671]
    Kernel driver in use: nouveau
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
01:00.1 Audio device [0403]: NVIDIA Corporation GP104 High Definition Audio Controller [10de:10f0] (rev a1)
    Subsystem: eVga.com. Corp. GP104 High Definition Audio Controller [3842:5671]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
03:00.0 PCI bridge [0604]: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge [1b21:1080] (rev 04)
05:00.0 Non-VGA unclassified device [0000]: YUAN High-Tech Development Co., Ltd. Device [12ab:0380]
    Subsystem: Device [1cfa:0003]
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]

If I need to downgrade to 18.04, that is perfectly fine; I just want to know whether such a downgrade is needed before I continue to set up the 19.04 system.

  • Did you run sudo apt install vulkan vulkan-utils command? Please edit your question and post the output of the command sudo ubuntu-drivers devices. Thanks – Marmayogi May 12 at 1:51
  • Yes, I did. The question has been edited with the output you requested. – PSDuckie May 12 at 1:54
  • Please run commands: 1. sudo apt-add-repository ppa:canonical-x/vulkan 2. sudo apt update and 3. sudo apt install vulkan vulkan-utils. Also post the output of lspci -knn | grep -A3 -i -E "(VGA|3D)" – Marmayogi May 12 at 2:23
  • @Marmayogi , I tried the first command you suggested and got an error, which I added to the question along with the lspci -knn | grep -A3 -i -E "(VGA|3D)" output. – PSDuckie May 12 at 2:28
  • FYI, Kernel driver in use is nouveau and NOT Nvidia whose latest version recommended for your Nvidia GPU is nvidia-driver-430 – Marmayogi May 12 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.