0

19.04

I'm setting up some IPV6 static addressing using netplan and want to put the ipv6 gateway.

 wifis:
   wlp3s0:
     dhcp4: no
     dhcp6: no
     addresses: [10.0.0.120/24,"fe00::120/64"]
     gateway4: 10.0.0.1
     gateway6: fe00::1

I take the gateway6 address from the /etc/hosts entry for ip6-localnet which is given as fe00::0 and the fact that the ipv4 gateway IP is 10.0.0.1

This configuration applies without errors or warnings and the host is accessible via ssh through its ipv6 address.

But though ping 10.0.0.1 gets a response ping6 fe00::1 does not. (Both ping and ping6 get responses from ..110)

So I have an error here somewhere.

  • How do you know that your local router is at fe00::1? fe00::/9 appears to be reserved. fe80::/9 is link local scope. – vidarlo May 11 at 17:29
  • @vidarlo I was just guessing from the /etc/hosts and the gateway ipv4 address. Bad guess, I guess. So : the netplan entry should be gateway6: fe80::1? That doesn't work either. – Stephen Boston May 11 at 18:12
  • No. The entry should be the actual gateway IP. You can find that through RA's or check what the actual IP of the gateway is. The normal thing with IPv6 would be to use DHCPv6 or SLAAC with public IP's on the host, and a router in the FE80::/9 subnet. – vidarlo May 11 at 18:14
  • Don't use manual IPv6 addressing if you can avoid it. It is too error-prone. Just enable DHCPv6 if your ISP provides IPv6, and forget about it. – Michael Hampton May 11 at 19:16
  • 1
    Difficult to configure, difficult to maintain, and unreliable hit all the high points. As you're using reserved space, instead of whatever might actually be appropriate, there's no way to know whether Linux will continue to accept your current configuration in the future. – Michael Hampton May 11 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.