0

I have have set Ubuntu studio 18.04 to not ask for a password at login, but I still have click the login button to get started.

How do I get Ubuntu Studio to auto login and go straight to the desktop on startup?

1

The above answer wasn't quite correct. The file to edit is /usr/share/lightdm/lightdm.conf.d/60-ubuntustudio.conf.

I added the following to the file as Mook765 sugested:

[Seat:*]
autologin-guest=false
autologin-user=yourusername
autologin-user-timeout=0

I had to use sudo nautilus to gain root privileges. Now working as I'd like.

  • It would be nice to see what changes you made to this file, could you please add this information to your answer? – mook765 May 16 '19 at 10:48
  • Apologies. I just edited my post. – Simon Monck-Mason May 16 '19 at 11:44
  • My answer should work as well, I selected the option to automatically login during installation. I guess the file /etc/lightdm/lightdm.conf didn't exist in your installation, so you edited /usr/share/lightdm/lightdm.conf.d/60-ubuntustudio.conf instead and that works too. – mook765 May 16 '19 at 12:17
0

Edit the file /etc/lightdm/lightdm.conf (if the file doesn't exist, create it), it should look like this:

[Seat:*]
autologin-guest=false
autologin-user=yourusername
autologin-user-timeout=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.