0

Last year I was given an HP ML350p Gen8 Server after it was retired from our company. I have been using it mainly for SETI@home crunching. It has always run M$ Windows Server as we have several old/unused versions kicking around.

Spec is:
2 x XEON E5 2697v2, 64GB RAM/Processor (128GB total), P830 12G Array Controller, 2 x SFF (Small Form Factor) 8 bay drive cages, 3 x 600BG 12G 15K SAS Drives configured RAID1+ADM and a 4th drive as a hot spare, 2 x 1,200watt PSU's currently configured PSU1 'live' PSU2 'redundant spare'. The machine is drawing about 450watts in total running 24 cores (48 threads) running 48 work unit tasks in parallel. I am (was) hoping to reduce the processing times with the K40 installed. I am familiar with the ILO interface and all temperatures are within tolerances, it is adequately cooled and lives in a dedicated shelf in my Server Cabinet in my office.

I recently bought a 'genuine (HP Part #'s) nVidia TESLA K40m and the HP Graphics Card Adaptor Kit. It was installed last week on Windows Server 16 the drivers install but the K40 returns a Code 12 (not enough resources to run the card) error. I've also tried Windows 10 and Server 2012 R2. I get the same error regardless of installed OS. The cards is installed in PCIe Slot 6 as instructed in the manual. The K40 was one of only 4 cards certified for use in the Gen8 ML350. In total I've spent over 70 hours researching the problem and trying to find a fix, I am convinced it's a BIOS/IRQ/PCIe setting but no amount of fiddling/tweaking removes the Code 12 error. I'm also running the most up to date BIOS 2018.05.21 both as main and backup. Both BIOS's have been refreshed just to make sure.
I have removed the P830 and used the embedded P420i Disk Controller that had no effect on the Code 12 problem either.

In frustration I installed openSUSE LEAP (latest version) and (and I have to be vague here as I know nothing about UNIX/LINUX) the K40 appeared to work. It was recognised in the HW/Device Manager type thingy (be gentle please, like I say I know nothing about LINUX/UNIX). Sadly my limited knowledge of the OS means I didn't know what else to do. I was just relieved it appeared to work.

I've spent the last couple of days chewing my way through posts and web-sites each extolling the virtues of various LINUX distro's. The ML350p Gen8 was originally certified for Ubuntu 14.04 LTS 64-bit, there are even Ubuntu drivers for 'stuff' on the HP Support web site!

My question. Can I install a later release of Ubuntu on the machine? What version? SERVER or DESKTOP? Can anyone point a LINUX newbie in the direction of installation guides for K40/nVidia etc? Once I have done this how can I test the K40 to really 'know' its installed, configured & working?

All this machine is going to do is crunch for SETI@home, nothing else.

  • So in short you want to install a newer version of Ubuntu on your system? You can try it yourself without actually installing it using Try Ubuntu. – Kulfy May 11 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.