0

I've been installing all the required dependencies for gpointing-device-settings which I don't have (figuring out by running ./configure and seeing what causes errors). But I've gotten to an error that I have not been able to get past.

screenshot of terminal displaying error message

I've done

  1. install gnome-settings-daemon but that doesn't stop the error
sudo apt-get install gnome-settings-daemon

and installing the .deb file which results in more dependency issues (which I get even though they are installed)

  1. add path of gnome-settings-daemon to PATH and to PKG_CONFIG_PATH
    added the following to .profile
export PATH="/usr/lib:$PATH"
export PATH="$HOME/usr/lib:$PATH"
PATH="/usr/lib:$PATH"
PATH="$HOME/usr/lib:$PATH"

have extra just in case (I'm a beginner and just wanted to make sure that I wasn't doing it wrong so I put in every combination)

paths as seen on terminal

  • Does it meet the required version for this install? – George Udosen May 11 at 9:18
  • You haven't told us your release, and as George has already said - does your release of Xubuntu meet the requirements (packages.ubuntu.com/…) Please don't provide pictures of text; we can't copy/paste them into windows (where as with text we can). – guiverc May 11 at 9:51
  • I think it's Xubuntu 18.04 (not sure if that's too vague). Also based on the link you sent me (guiverc), am I supposed to add the specified line to "/etc/apt/sources.list" and install the .deb file they provide? Or just do one of the two? Or do something completely different? I'm a beginner and don't yet understand how it all works. Installing the .deb file doesn't seem to work (but I may be doing it wrong) – Daniel Gros May 11 at 10:32
0

It seems that you are trying to compile the program its source code.

In such case you need to install special development packages (with -dev) suffix.

As the result you will get needed headers and Pkg-Config file(s) - .pc.

In this particular case you need to enable source code repositories in Software & Updates (software-properties-gtk) and install gnome-settings-daemon-dev package with:

sudo apt-get install gnome-settings-daemon-dev

and then proceed.


Also you can try to use binary packages way:

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/universe/g/gpointing-device-settings/libgpds0_1.5.1-6ubuntu2_amd64.deb
sudo apt install ./libgpds0_1.5.1-6ubuntu2_amd64.deb

wget http://archive.ubuntu.com/ubuntu/pool/universe/g/gpointing-device-settings/gpointing-device-settings_1.5.1-6ubuntu2_amd64.deb
sudo apt install ./gpointing-device-settings_1.5.1-6ubuntu2_amd64.deb

About your original problem - you can find this thread about touchpad-indicator useful.

  • that did fix the issue I was having with gnome-settings-daemon, thanks! I tried touchpad-indicator, but it has some defaults that I don't think I can change (like mouse acceleration). So I've removed it. I'm still hoping to install gpointing-.... do you think that would work? Based on the little I read from the post you linked gpointing-... has been discontinued and probably won't work for a Xubuntu 18.04 system. Do you know of another way I could disable the tap to click? (pretty much all I want to do, causes a lot of issues for me) – Daniel Gros May 11 at 10:59
  • I'm not familiar with tap-to-click problem, some posts here mention synclient, but I have never used it. On my MATE system I have set it in mate-mouse-properties (see image). If you want to proceed with gpointing-device-settings, you can try binary packages first (see update above). – N0rbert May 11 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.