5

I am trying to play a MKV file with Totem and on some files I get the following message:

Unable to play the file
PGS subtitles decoder is required to play the file, but it is not installed
Cancel / Find in Ubuntu Software

  • Selecting the "Find in Ubuntu Software" button reveals nothing.
  • apt search pgs finds nothing that I can identify that would help resolve the issue.
  • "Cancel" allows the file to play, but obviously without subtitles.
  • Google and AskUbuntu have been no help.

This is a new install of 19.04 (but an old $HOME directory). I was playing these files just fine with 18.10.

(And to preempt a common refrain for problems like this, I don't want to "just use VLC". I want Totem to work.)

0

1 Answer 1

9

The Totem installation on Ubuntu 19.04 Disco Dingo is missing a couple of decent gstreamer plugins by default. To get a better experience with this media player (and get PGS subtitle support) you will need to also install the following 'recommended' and 'suggested' packages which are not installed by default:

  1. recommended: gstreamer1.0-pulseaudio totem-plugins
  2. suggested: gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly

It is the gstreamer1.0-plugins-bad package that contains the plugin for PGS subtitles and certainly on my system with this installed PGS subtitles roared into life. A single command will install all of these extras:

sudo apt-get install gstreamer1.0-libav gstreamer1.0-plugins-bad \
     gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio totem-plugins

And then all should be well :)

References:

2
  • That's annoying... I had specifically chosen the "install codecs" (or whatever) option when installing Ubuntu 19.04, which included bad and ugly. That worked in 18.04 but apparently not anymore. Thanks!
    – Cliff
    May 11, 2019 at 19:49
  • 1
    @Cliff Great to hear it is all working nicely, and thanks for spurring me along to actually install 19.04 (on VM). It looks great!
    – andrew.46
    May 12, 2019 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.