0

Warning: I installed Ubuntu manually. 18.04 is installed, and when I run it manually from the Windows 10 PowerShell it opens. When I attempt to open Ubuntu in the Programs list by clicking on the Windows logo and clicking on Ubuntu it fails with the message above. If I open services I see nothing for Ubuntu so the fail makes sense. There is a longer error note as follows: C:\Program Files\WindowsApps\CanonicalGroupLimited.Ubuntu18.04onWindows_1804...\ubuntu1804.exe above the fail. I follow all this to double click on the executable and a window flashes open and closed in a millisecond. Uninstalling and reinstalling results in the same behavior. I had to stop working 15 years ago so I'm no longer well versed in Unix or Windows much less Linux. If you have an answer please phrase it as you would for a junior high school student. Thanks.

  • Ru this as admin in CMD sc stop LxssManager & sc start LxssManager. – Biswapriyo May 11 at 13:10
  • Can't read file "LxssManager" Then it opened what looked like a spreadsheet with capital letters along the top edge and numbers down the left side. The same error message appeared when I tried to click on the program listing and there's no service listing. – R. L. May 12 at 1:07
0

Turns out that WSL was never meant to run anything other command-line Ubuntu. I was referred to a Microsoft page which said Gnome, etc. will not operate under the Linux Subsystem; it was never intended for that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.