-1

Im trying to get battle.net installed and working on my Linux Mint PC, but its not working. I followed this DXVK installation guide, installed everything as directed and tried to install the launcher through Lutris.

Unfortunately the install gets stuck at about 50%. I tried installing again on a different drive (in case my main drive was NTFS) but I get the same error.

Here are is the error shown in the logs.

0069:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
0069:fixme:wbemprox:client_security_SetBlanket 0x7d3c8938, 0x15d478, 10, 0, (null), 3, 3, (nil), 0x00000000
0069:fixme:wbemprox:client_security_Release 0x7d3c8938
0069:fixme:wbemprox:enum_class_object_Next timeout not supported
0069:fixme:ver:GetCurrentPackageId (0x33fe14 (nil)): stub
006b:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
006b:fixme:wbemprox:client_security_SetBlanket 0x7cb5b938, 0x17bb60, 10, 0, (null), 3, 3, (nil), 0x00000000
006b:fixme:wbemprox:client_security_Release 0x7cb5b938
006b:fixme:wbemprox:enum_class_object_Next timeout not supported
006f:fixme:ver:GetCurrentPackageId (0x1b9fe9c (nil)): stub
006b:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  183
  Current serial number in output stream:  187

closed as off-topic by karel, Kulfy, user535733, Eric Carvalho, qbi May 13 at 20:22

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – karel, Kulfy, user535733, Eric Carvalho, qbi
If this question can be reworded to fit the rules in the help center, please edit the question.

  • ??? Why the downvotes? I m asking a genuine question and providing all the information I can? – umbro_tracksuit May 11 at 6:48
  • I think you were downvoted because you have Mint, not Ubuntu. – SurvivalMachine May 11 at 8:26
  • Mint is based on ubuntu so I assumed if there was an ubuntu fix it would work on mint anyway – umbro_tracksuit May 11 at 9:25
  • While Mint is indeed "based upon" Ubuntu, we don't keep track of what changes Mint and other derivatives make to stock Ubuntu. So we don't know if an Ubuntu solution would work for Mint. Also, it's customary to use your own distro's help channels. – user535733 May 12 at 15:35
1

FIXED THE ISSUE!

For some reason, I did not have all the relevant 32-bit libraries, so I ran the following command:

sudo apt install libnvidia-gl-418:i386

Just change the 418 to whatever version you have installed!

Not the answer you're looking for? Browse other questions tagged or ask your own question.