0

Printing was working yesterday but stopped for some unknown reason. The only thing I did was to alter some of the editable printer settings but now don't have the option to change them back. I tried one answer already posted in this forum ("Printing service not available") but without success.

I then found Question, "system printing service not available ubuntu 18.10" and ran: systemctl status cups.service which returned

   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: start-limit-hit) since Fri 2019-05-10 12:53:47 BST; 35min ago
     Docs: man:cupsd(8)
  Process: 4222 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
 Main PID: 4222 (code=killed, signal=TERM)

May 10 12:53:47 mike-XPS-13-9370 systemd[1]: cups.service: Service hold-off time over, scheduling restart.
May 10 12:53:47 mike-XPS-13-9370 systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
May 10 12:53:47 mike-XPS-13-9370 systemd[1]: Stopped CUPS Scheduler.
May 10 12:53:47 mike-XPS-13-9370 systemd[1]: cups.service: Start request repeated too quickly.
May 10 12:53:47 mike-XPS-13-9370 systemd[1]: cups.service: Failed with result 'start-limit-hit'.
May 10 12:53:47 mike-XPS-13-9370 systemd[1]: Failed to start CUPS Scheduler.

I also tried this:

mike@mike-XPS-13-9370:~$ systemctl status cups.socket
● cups.socket - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.socket; enabled; vendor preset: enabled)
   Active: failed (Result: start-limit-hit) since Fri 2019-05-10 12:29:05 BST; 2h 23min ago
   Listen: /run/cups/cups.sock (Stream)

May 10 12:29:05 mike-XPS-13-9370 systemd[1]: Listening on CUPS Scheduler.
May 10 12:29:05 mike-XPS-13-9370 systemd[1]: Closed CUPS Scheduler.
May 10 12:29:05 mike-XPS-13-9370 systemd[1]: Stopping CUPS Scheduler.
May 10 12:29:05 mike-XPS-13-9370 systemd[1]: cups.socket: Start request repeated too quickly.
May 10 12:29:05 mike-XPS-13-9370 systemd[1]: cups.socket: Failed with result 'start-limit-hit'.
May 10 12:29:05 mike-XPS-13-9370 systemd[1]: Failed to listen on CUPS Scheduler.

The computer is a Dell XPS, with Intel® Core™ i7-8550U CPU @ 1.80GHz × 8 processors; Intel® UHD Graphics 620 (Kabylake GT2) Graphics; running Gnome 3.28.2 and is 64 bit. I am the only user but when I run a search for "cups", the file system only shows the .cups folder, which only has 1 file (lpoptions), in Home>Mike>.cups.

If I try the Troubleshooter, it tells me to look in Main>System>Admin>Services for the cups service but I can't find the Main menu, which I notice someone else has also had a problem finding!

I am a complete novice when it comes to Linux, so need leading gently by the hand. Thanks!

  • In your browser type localhost:631 to access the CUPS service – Graham May 10 at 14:06
  • Thanks, Graham, I tried that but it didn't work: "This site can’t be reached localhost refused to connect." – KersalMike May 10 at 14:27
  • Does this link help? help.ubuntu.com/lts/serverguide/cups.html.en – Graham May 10 at 14:32
  • If I run, "sudo apt install cups", it returns "cups is already the newest version (2.2.7-1ubuntu2.4)" How do I find "/var/log/cups/error_log"? I tried searching the Home directory but it found nothing. – KersalMike May 10 at 14:39
  • 1
    So the corrected version is: copy the original over the one in use sudo cp /etc/cups/cupsd.conf.O /etc/cups/cupsd.conf then restart the service sudo service restart cups – Organic Marble May 10 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.