1

I am trying to install Packet Tracer on Ubuntu 19.04, but it gives me the error below when I try to launch it:

./PacketTracer7: ./libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7)

But when I try to install libssl1.0.0 I get the following error:

**Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl1.0.0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source**

**E: Package 'libssl1.0.0' has no installation candidate**

I also collected a debug for this:

Reading symbols from PacketTracer7...
(No debugging symbols found in PacketTracer7)
(gdb) run
Starting program: /opt/pt/bin/PacketTracer7 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeda96700 (LWP 2775)]
[New Thread 0x7fffece7a700 (LWP 2776)]
[New Thread 0x7fffa7ffd700 (LWP 2778)]

Thread 1 "PacketTracer7" received signal SIGSEGV, Segmentation fault.
0x00000000034602dc in CDeviceTypesBox::CDeviceTypesBox(QVector<SDeviceTypes_t*>, QWidget*, char const*, QFlags<Qt::WindowType>) ()
(gdb) where
#0  0x00000000034602dc in CDeviceTypesBox::CDeviceTypesBox(QVector<SDeviceTypes_t*>, QWidget*, char const*, QFlags<Qt::WindowType>) ()
#1  0x0000000003473201 in CNetworkComponentBox::CNetworkComponentBox(QWidget*, char const*, QFlags<Qt::WindowType>) ()
#2  0x0000000002e9ba0a in Ui_CAppWindowBase::setupUi(QMainWindow*) ()
#3  0x0000000002e96b26 in CAppWindow::CAppWindow(QWidget*, char const*, QFlags<Qt::WindowType>) ()
#4  0x000000000341c801 in oldMain(int, char**) ()
#5  0x00007ffff406cb6b in __libc_start_main (main=0x541620 <main>, argc=1, 
    argv=0x7fffffffdf48, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7fffffffdf38)
    at ../csu/libc-start.c:308
#6  0x000000000054ad79 in _start ()

Thanks in advance for helping me. And again, excuse my lack of technical knowledge to explain this issue.

1

You can try downloading one from 18.10 repository, since it's yet to be available on 19.04.

wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu6.2_amd64.deb
sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu6.2_amd64.deb
  • Thanks for your answer Jim (and for the url to the package), I ran the commands and it seems they were successful: (Reading database ... 159000 files and directories currently installed.) Preparing to unpack libssl1.0.0_1.0.2n-1ubuntu6.2_amd64.deb ... Unpacking libssl1.0.0:amd64 (1.0.2n-1ubuntu6.2) over (1.0.2n-1ubuntu6.2) ... Setting up libssl1.0.0:amd64 (1.0.2n-1ubuntu6.2) ... Processing triggers for libc-bin (2.29-0ubuntu2) ... But I keep getting the same error when I try to execute Packet Tracer. – tierianoob May 10 at 6:21
  • @tierianoob Try this sudo cp -i /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/pt/bin/ press y to confirm overwrite. Solution from YT – Jim May 10 at 6:31
  • I ran it, and not it doesn't complain about the library, I only get this error: Segmentation fault (core dumped) – tierianoob May 10 at 6:34
  • @tierianoob Do you have /opt/pt/bin dir ? Can you by any chance copy it manually ? – Jim May 10 at 6:36
  • I did it manually but got the same error as I tried to run it. However, when I tried to ran it as root, it took longer and eventually returned the same message but didn't mention any core dump. Do you know where could I find this coredump? – tierianoob May 10 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.