0

I tried installing KDE Plasma in Ubuntu 18.04, but the installation seemed to crash right after running tasksel, so I interrupted it by ctrl+c (my bad, I know).

Now, when I try to start the installation again, or use apt-get again, I get unmet dependencies error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 xserver-xorg : Depends: xserver-xorg-core (>= 2:1.17.2-2)
                Recommends: xserver-xorg-video-all

I tried removing all the packages that have dependencies using

sudo dpkg --remove --force-remove-reinstreq xserver-xorg
sudo dpkg --remove --force-remove-reinstreq ...

but it goes up to ubuntu-desktop package - and I dont know if I should remove that one.

apt --fix-broken install

does nothing.

Can you help me with this one?

Thank you.

EDIT:

apt-cache policy xserver-xorg-core

gives

xserver-xorg-core:
  Installed: 2:1.20.4-1ubuntu3
  Candidate: 2:1.20.4-1ubuntu3
  Version table:
 *** 2:1.20.4-1ubuntu3 100
        100 /var/lib/dpkg/status
     2:1.19.6-1ubuntu4.2 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     2:1.19.6-1ubuntu4 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

EDIT2:

I looked into log of apt. At the end I found this:

Removing xserver-xorg-video-all-hwe-18.04 (1:7.7+19ubuntu8~18.04.2) ...^M
 577 Removing xserver-xorg-video-vmware-hwe-18.04 (1:13.3.0-2build1~18.04.1) ...^M
 578 Removing xserver-xorg-video-amdgpu-hwe-18.04 (18.1.0-1~18.04.1) ...^M
 579 Removing xserver-xorg-video-vesa-hwe-18.04 (1:2.4.0-1~18.04.1) ...^M
 580 Removing xserver-xorg-video-ati-hwe-18.04 (1:18.1.0-1~18.04.1) ...^M
 581 Removing xserver-xorg-video-radeon-hwe-18.04 (1:18.1.0-1~18.04.1) ...^M
 582 dpkg: xserver-xorg-hwe-18.04: dependency problems, but removing anyway as you requested:^M
 583  xorg depends on xserver-xorg (>= 1:7.7+19ubuntu7.1); however:^M
 584   Package xserver-xorg is not installed.^M
 585   Package xserver-xorg-hwe-18.04 which provides xserver-xorg is to be removed.^M
 586 ^M
 587 Removing xserver-xorg-hwe-18.04 (1:7.7+19ubuntu8~18.04.2) ...^M
 588 Selecting previously unselected package xserver-xorg.^M
 589 (Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading                database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ...        30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading       database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Reading database ...        65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading       database ... 85%^M(Reading database ... 90%^M(Reading database ... 95%^M(Reading database ...        100%^M(Reading database ... 276999 files and directories currently installed.)^M
 590 Preparing to unpack .../xserver-xorg_1%3a7.7+19ubuntu7.1_amd64.deb ...^M
 591 Unpacking xserver-xorg (1:7.7+19ubuntu7.1) ...^M

EDIT3:

sudo apt install xserver-xorg-core:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
xserver-xorg-core is already the newest version (2:1.20.4-1ubuntu3).
xserver-xorg-core set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 aptitude:i386 : Depends: aptitude-common:i386 (= 0.8.11-7)
                 Depends: libapt-pkg5.0:i386 (>= 1.1) but it is not going to be installed
                 Depends: libboost-iostreams1.67.0:i386 but it is not installable
                 Depends: libboost-system1.67.0:i386 but it is not installable
                 Depends: libcwidget3v5:i386 (>= 0.5.17-8) but it is not going to be installed
                 Depends: libncursesw6:i386 (>= 6.1+20180210) but it is not installable
                 Depends: libsigc++-2.0-0v5:i386 (>= 2.8.0) but it is not going to be installed
                 Depends: libsqlite3-0:i386 (>= 3.6.5) but it is not going to be installed
                 Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed
                 Depends: libtinfo6:i386 (>= 6.1+20180210) but it is not installable
                 Depends: libxapian30:i386 (>= 1.4.10~) but it is not going to be installed
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 xserver-xorg-core : Depends: xserver-common (>= 2:1.20.4-1ubuntu3) but 2:1.19.6-1ubuntu4.2 is to be installed
                     Depends: libc6 (>= 2.29) but 2.27-3ubuntu1 is to be installed
 xserver-xorg-input-libinput-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
 xserver-xorg-input-wacom-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
 xserver-xorg-video-all : Depends: xserver-xorg-video-ati
                          Depends: xserver-xorg-video-vesa
                          Depends: xserver-xorg-video-vmware
 xserver-xorg-video-fbdev-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
 xserver-xorg-video-intel-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
 xserver-xorg-video-nouveau-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
 xserver-xorg-video-qxl-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

cat /etc/apt/sources.list:

# deb cdrom:[Ubuntu 18.04.2 LTS _Bionic Beaver_ - Release amd64 (20190210)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://sk.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://sk.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic universe
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://sk.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://sk.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://sk.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

  • A quick scan of a dependency (packages.ubuntu.com/…) shows 1.19.6 is available for bionic (meeting the requirement listed in your message) so I'd check your sources for it, ie. apt-cache policy xserver-xorg-core, though probably not before sudo apt update to be safe. note: I don't use tasksel so I could easily be missing something in how it works, I'd have installed with kubuntu-desktop The `apt-cache policy command & output can be added to your question – guiverc May 9 at 22:32
  • Edited the post. I tried to install all of the dependent packages manually, but it seems to be endless list. – Stannxx May 9 at 22:44
  • Edit the post to include the output of sudo apt install xserver-xorg-core and cat /etc/apt/sources.list – Olimjon May 9 at 22:55
  • The post is edited as you wished. – Stannxx May 9 at 23:03
  • I checked you mirror (which appears to be vnet which is only a few hours behind), however I note two architectures (x86_64 [amd64] & x86 [i386]) listed which I suspect is your issue – guiverc May 10 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.