0

I'm trying to build myself a multi-OS-boot USB flash drive, incl. Windows and Linux OS's.
I am using Linux as the tool/utiliy machine.

Win10 ISO file SW_DVD9_Win_Pro_Ent_Edu_N_10_1809_64-bit_English_MLF_X21-96501.ISO

Content of ISO file when mounted):
enter image description here

I've tried the following:

  • Using dd if=my.iso of=/dev/sda3 bs=1M to "burn" the ISO directly to the partition. But the partiton is somehow not readable by neither WinPE or EFI. Running diskpart in WinPE list the partition as RAW. Linux lsblk list the partition as FS=udf. EFI cannot see it when I try to browse to the partition for the efi boot file.
  • Mounted the ISO file and tried both tar and cp to copy all files and folders to the partition (formated as FAT32). But tar gave a lot of permissions errors on many of the files and cp couldn't copy the /sources/install.wim as it's above 4GB!
  • Tried to copy files/foldes to the partition formated as NTFS. Now I could copy everything but now the EFI cannot read the \EFI subfolder so I have to do a bcdboot from WinPE, but it give the error Failure when attempting to copy boot files. Not sure if it cannot find source files or the target EFI partition on the usb flash drive (could not assign drive-letter to it from diskpart).

I ran out of ideas....help!

I guess I could just copy c:\bootmgr.efi to the EFI parition and make a boot entry for it (using systemd-boot) but it doesn't know which parititon Windows is installed to, i assume bscboot would fix that, right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.