0

I have a Dell Precision M6800 (laptop), and I recently switched from Neon to Kubuntu. In Kubuntu I get a loud buzz from my speakers whenever nothing is playing. They're fine when I'm playing music or a video, etc., but when the music ends there's a roughly six second pause and then a loud buzz which persists until I play some other music or sound.

My guess is that this is related to power management: something is suspending power to the audio system after it's been idle for a few seconds.

When I pull the 1/8" cable out of the laptop there's silence, but when I touch my finger to the end I get the same buzz.

When I pull out the power cord and run on battery I still get the buzz but it's much quieter.

I'm confident that it's not a hardware issue: I haven't experienced this in Windows or OpenSUSE or Neon, only Kubuntu.

I think I would just need to disable this power management? It's not the same as the "Battery and Brightness" power management, I've tried disabling that and there's no change. If anyone can tell me how to do this I'd appreciate it.

Outputs of the commands are listed:

$ pulseaudio --check -v
I: [pulseaudio] main.c: Daemon running as PID 1448

$ cat /sys/module/snd_hda_intel/parameters/power_save_controller
Y

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]

$ ls -l /etc/modprobe.d/idle-audio.conf
file not found
  • Please issue the command mv ~/.config/pulse ~/.config/old_pulse. Reboot your system. Now, please check your audio. If it fails, then try this command sudo alsa force-reload. Now again check for audio. Also please post the output of pulseaudio --check -v command. – Marmayogi May 9 '19 at 19:17
  • No change in either of those cases, output is: "I: [pulseaudio] main.c: Daemon running as PID 1448" – buzzer May 10 '19 at 3:03
  • Please edit your question and post output of the following commands: 1. cat /sys/module/snd_hda_intel/parameters/power_save_controller 2. lspci | grep -i audio and 3. ls -l /etc/modprobe.d/idle-audio.conf – Marmayogi May 10 '19 at 7:23
  • Okay, I added that information. The problem seems to be solved now, thank you very much for that, but have I caused any other problems in doing it this way? – buzzer May 10 '19 at 11:13
  • 1
    I appreciate the need to keep things clear for anyone else who might read this, but I had wanted to ask if my solution created any other problems (thinking mostly about battery life). I created the file idle-audio.conf, acting on Marmayogi's question, and added the line: "options snd_hda_intel power_save=0" – buzzer May 10 '19 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.