2

I don't have the opportunity to install figma on my ubuntu 18.04

After install figma I have error:

/snap/figma-linux/2/figma-linux: error while loading shared libraries:
 libpng16.so.16: cannot open shared object file: No such file or directory
  • 1
    issue ... apt-file search libpng16.so ... to show packages which contain that file then install one of them – Scott Stensland May 9 '19 at 16:11
  • @scott-stensland, there is only libpng16-16 package, which is already installed by default. Despite that figma-linux does not run. – Sasha MaximAL May 16 '19 at 13:35
6

I also encountered above errors however I did manage to launch it on ubuntu 19.04 using

download the binary file from

https://github.com/ChugunovRoman/figma-linux/releases

on Ubuntu pick one called

figma-linux_0.5.1_amd64.deb

who has direct link https://github.com/ChugunovRoman/figma-linux/releases/download/v0.5.1/figma-linux_0.5.1_amd64.deb

once downloaded install using

sudo dpkg -i figma-linux_0.5.1_amd64.deb

On Ubuntu 19.04 I get this

Selecting previously unselected package figma-linux.
(Reading database ... 253481 files and directories currently installed.)
Preparing to unpack figma-linux_0.5.1_amd64.deb ...
Unpacking figma-linux (0.5.1) ...
dpkg: dependency problems prevent configuration of figma-linux:
 figma-linux depends on libappindicator1; however:
  Package libappindicator1 is not installed.

dpkg: error processing package figma-linux (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 figma-linux

so now issue

sudo apt-get --fix-broken install -y 
sudo apt-get install libappindicator1   libdbusmenu-gtk4  
sudo dpkg -i figma-linux_0.5.1_amd64.deb

then upon first launch you will get this error (see workaround)

scott@berghia ~/Downloads $ figma-linux   
A JavaScript error occurred in the main process
Uncaught Exception:
Error: ENOENT: no such file or directory, open '/home/scott/config/figma-linux/Settings'
    at Object.openSync (fs.js:436:3)
    at Object.module.(anonymous function) [as openSync] (ELECTRON_ASAR.js:160:31)
    at Object.writeFileSync (fs.js:1168:35)
    at Object.writeFileSync (/opt/figma-linux/resources/app.asar/node_modules/jsonfile/index.js:117:13)
    at Settings._ensureSettings (/opt/figma-linux/resources/app.asar/node_modules/electron-settings/lib/settings.js:153:18)
    at Settings._readSettings (/opt/figma-linux/resources/app.asar/node_modules/electron-settings/lib/settings.js:192:10)
    at Settings._getValueAtKeyPath (/opt/figma-linux/resources/app.asar/node_modules/electron-settings/lib/settings.js:281:22)
    at Settings.get (/opt/figma-linux/resources/app.asar/node_modules/electron-settings/lib/settings.js:404:17)
    at Object.<anonymous> (/opt/figma-linux/resources/app.asar/main/main.js:1:18900)
    at o (/opt/figma-linux/resources/app.asar/main/main.js:1:279)

so pure guesswork I created its missing config file using

mkdir -p ~/config/figma-linux
touch ~/config/figma-linux/Settings

finally it launched OK with a

figma-linux

have fun

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.