1

Ubuntu 19.04 is what I'm working with. I am trying to determine the best way to change an icon for this stand alone program, https://www.balena.io/etcher/?ref=etcher_footer

I tried copying program file to the desktop, opening the properties dialog box,clicking icon, and selecting new one. The icon changes in the properties dialog box, but not on the actual program file.

The permisions tab in properties shows that the file is owned by "root", and in the group "root". Then I tried opening nautilus as root, and changing "user" and "group" in properties/permissions. Still no change.

It's probably something simple, but I'm just spinning my wheels here. Any help would be great.

@Jim Using info on this site, https://itsfoss.com/use-appimage-linux/ I was able to integrate the appimage into Applications menu, though there still remained the problem of changing is icon, after installing .deb files from gitHub repository you posted your solution worked.

Apparently the AppImage icon issue has been going on for some time. https://github.com/AppImage/AppImageKit/issues/346

1

This is assuming you installed etcher from their repository or .deb files.

  1. Open up terminal
  2. Navigate to Ubuntu's application global dir.

    cd /usr/share/applications
    
  3. Edit the Etcher's desktop entry.

    sudo gedit balena-etcher-electron.desktop
    
  4. Change Icon= value to your image file location. Mine was in ~/Downloads folder so put it like this.

    [Desktop Entry]
    Name=balenaEtcher
    Comment=Flash OS images to SD cards and USB drives, safely and easily.
    Exec="/opt/balenaEtcher/balena-etcher-electron" %U
    Terminal=false
    Type=Application
    Icon=/home/user/Downloads/GitLab_Logo.svg.png
    StartupWMClass=balenaEtcher
    Categories=Utility;
    
  5. Save and exit to apply changes.

  6. Run sudo updatedb to update database.
  7. The icon will changes then.

From

enter image description here

To

enter image description here

  • Actually I downloaded the program from their website, but I will try it the way you said. – joeRag May 9 at 1:50
  • I downloaded it via .deb file from this link balena-etcher-electron_1.5.33_amd64.deb, however if you uses repo as this github.com/balena-io/etcher#installers instruct, then this should work too. – Jim May 9 at 1:59
  • I didn't see it in synaptic, but searching for an etcher repository I ran accross this site, that described how to install an appimage in Linux. Sure enough the etcher file for Linux from is an appimage. It's like an .exe; one file. – joeRag May 9 at 2:14
  • You have to add the repository first in order to install it in synaptic, etcher doesn't exist on default repository, instead it have it own third party repository. – Jim May 9 at 2:15
  • I should have mentioned that in my question.I actually never heard of an appimage, but this site, ubuntu-mate.community/t/… describes how it can be installed. It now shows up in the program list. – joeRag May 9 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.