1

I am trying to set up a wireless access point on my raspberry pi 3B (running Ubuntu 18.04 server) using netplan. The documentation seems to imply that I can do this by specifying mode: ap in the .yaml configuration file for netplan (located in /etc/netplan folder). However, when trying to apply the netplan, I get the following error: wlan0: netowrkd does not support wifi in access point mode. I know for a fact that the adapter itself supports AP mode, since I've successfully used it before using a slightly different procedure that involved purging netplan and using hostapd directly. I would like to stick with netplan this time because this way I can easily switch between AP and managed modes by switching out the .yaml file. Is there any way I can get past this error?

  • How did you set the AP on netplan? I can't find how to put passphrase, ap_isolate, etc. – Oxwivi Aug 18 '19 at 15:18
  • 1
    In the 50-cloud-init.yaml file (or equivalent in /etc/netplan), after "wifis", "wlan0", and "dhcp4", on the next line I have: 'access-points: "SSID" mode: ap password: "PASSWORD" mode: ap' Indentation is 4 spaces where applicable. – anvoice Aug 19 '19 at 17:14
  • 1
    While I tried to format the comment, commenting time ran out. Here's the proper formatting: dhcp4: true access-points: "piRobot": password: "181081Robot" mode: ap Edit: ok formatting still won't show up in code. Anyway, "access points" on same line as "dhcp4", then next line, 4 spaces right is SSID, then next line 4 spaces right is "ap password", then "mode" is on next line, no spaces. – anvoice Aug 19 '19 at 17:22
  • Could you please answer me here: askubuntu.com/q/1166619/814? Please include your source of reference, I'd like to see all the settings available to me. – Oxwivi Aug 19 '19 at 17:26
4

As documented in netplan(5):

ap is only supported with NetworkManager.

You must specify renderer: NetworkManager and install the network-manager package to put a wifi interface in ap mode with netplan, because as stated, this is not implemented with the networkd backend.

| improve this answer | |
  • Yep, thank you. Just found that solution. – anvoice May 9 '19 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.