0

I've tried to strace a program and send the strace's output to a file x.deb. After opening x.deb I've seen this:

x.deb:

*** Contents:
x.deb (END)

I thought it is a bug in strace, because if I used x.x instead of x.deb, then the result was correct. But (I don't know why) when I opened x.deb with a cat, then it shown the actual content of the file, so... if it is a bug, then the bug is in the less, not in strace. But I'm not sure if it is a bug, because I've tried it with more versions of command less with the same result. What is it? Could you help me?

  • Tried versions off less: 481 on Ubuntu 16.04, 487 on Ubuntu 18.04 – H.Z. May 8 at 7:57
2

The name of the file ends with .deb so the less command thinks that the file is a Debian package and tries to provide an unpacked view of the package. However, the data you are providing is just plain ASCII output from strace and not a Debian package so the less command can't unpack it.

If you use another filename without the .deb suffix it will work OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.