0

I had a fully functional 19.04 machine until I rebooted today. Now the machine boots to a blinking cursor on a black screen. Since pressing the power button results in an immediate shutdown, it appears nothing has loaded.

I see there are a couple of other posts regarding 10.04 and booting. However, I can't try any of the suggestions as these there methods all go to a blinking cursor - booting from HD - holding left shift while booting - booting from a 19.04 USB

System is a Dell 8900 with NVIDA graphics, i7 processor. Had been running 18.04 without problem for a year. 19.04 was installed as a fresh install, not upgrade.

The same thing happened a few days ago but I was able to hold down left shift, get into the utility (not sure what it is called), updated GRUB and then it rebooted.

Any suggestions?

  • If you want to boot from external media you need to open UEFI settings and use the boot override or the one-time boot menu. It's an hardware characteristic/feature independent of the installed OS. – GabrielaGarcia May 7 at 18:03
  • Thanks @GabrielaGarcia, I had already done that. – klequis May 7 at 18:25
  • After a few more tries to boot from USB it succeeded. I exited without doing anything. Then I changed the boot options so the only choice was 'Hard drive' which in my case is the Ubuntu 19.04 install. System booted just fine. A bit of a mystery going on. – klequis May 7 at 18:26
  • It has been 9 days since I disabled all Gnome extensions and I have experienced no problems since. Looks likely it was an extension problem. – klequis May 16 at 13:11
0

I had this problem with an nvidia card and Ubuntu 19.04 on a desktop. Workarounds that I found were:

  • When at the screen with the blinking cursor, press Ctrl+Alt+F2 and then Ctrl+Alt+F1 (or some variation of this until the login screen appears).
  • Use the lightdm package to handle logins instead of gdm (however, I found a minor issue with the mouse cursor size with a 4K display when I used this solution).
  • Edit /lib/systemd/system/gdm.service and comment out the ExecStartPre line with a '#' and then add ExecStartPre=sleep 5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.