2

I have very long queries text (~50 lines). Recently MySQL workbecnh is exhibiting strange behavior. While editing the query (I open it, I edit one character and want to continue to the next), it freezes forever.

I suspect it can be something related to memory? I see in the preferences there is a default value for maximum query length to store in history in bytes with this default value: 65536. Is this relevant? What do you suggest?

My device is running Ubuntu 18.04 and the workbench is verion 8.0 which is the latest. I cleaned the temp files using: clean and autoclean commands but no hope.

Please help me how to overcome this problem. Knowing that I do not face it when I edit the query in a text editor. Just when I am using the workbench editor. But it is not practical to use external editor.

I also tried to reboot and shut down my device and open the database connection again.

If you need the log, please specify the step to get it for you.

3 Answers 3

2

I solved it by disabling Code Completion in PreferencesQuery Editor.

1

Not an answer, but it can help you debug if it's a memory problem

1.- Open mysql-workbench from a terminal window with mysql-workbench --log-level=debug3 -v

2.- Open a second terminal and run this command to monitor the memory and set a baseline, it will autoupdate every 2 seconds (in GB)

while true; do ps aux | grep 'mysql-workbench-bin' | grep -v -E 'grep|catchsegv' |  awk '{$5=int(100 * $5/1024/1024)/100"GB";}{ print;}' | awk '{print $5" "$11}'; sleep 2; done

It will output something like this 0.93GB /usr/lib/mysql-workbench/mysql-workbench-bin every 2 seconds.

3.- Open the query in mysql-workbench and monitor the increase of memory (if any).
Also check the output of the terminal running mysql-workbench.

4.- Open a 3rd terminal and run htop, that will give you an overview of the general usage (cpu/memory/swap) of your system.

0

I solves this changing some DBMS settings in SQL Editor:

enter image description here

3
  • 4
    You don't mention which of those settings you changed.
    – lolcode
    Jul 22, 2020 at 17:19
  • didn't help on windows 10, not responding even when just editing SQL
    – Fisk
    Mar 1 at 10:24
  • @lolcode I said DBMS MySQL session settings. I put a 0 after each DBMS setting.
    – Florin
    Mar 2 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.