1

Under System -> Administration -> Printers, the window shows a printer that no longer exists:

enter image description here

My wife used to have Brother J470DW printer (physically attached) hanging off her Mac Desktop. She got rid of that computer and acquired a new one. I never installed the Brother printer under printers on my laptop --- as far as I could tell this would have been no use, since, as far as I could tell, it was not WiFi connected. But somehow my laptop "knew about it". But now it's gone and my laptop still knows about it!

I've repeatedly tried to delete it --- the icon disappears momentarily and then immediately re-appears. I's an unimportant nuisance, but it's irritating.

Is there any way that I can get rid of the thing?

(The printer "TS9100LAN" that shows up in the screenshot is my wife's new printer which is WiFi connected, rather than cable connected, and after considerable travail I managed to obtain and install a printer driver for it, and can now print to it.)

0

First, you need to remove the unwanted printers.

Then

sudo nano /etc/cups/cups-browsed.conf

and edit this line

BrowseRemoteProtocols dnssd cups (or whaterver is after it)

to none so that it reads:

BrowseRemoteProtocols none

Then save the file and reboot.

0

you will have to turn off auto-discovered printers. for that, you will need to reconfigure the settings. and after that, it won't show any additional printer except the printers you have added manually.

In /etc/cups/cups-browsed.conf set directive: BrowseProtocols none

now restart the service by

service cups-browsed restart
service cups restart

that's all. your problem will be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.