2

I tried loading Adobe Flash player in Chromium on Ubuntu 19.04 (Lubuntu in this case) using various answers on AskUbuntu.com. I get to the point where the Allow Flash popup happens. But when I click to allow it, it says "Right-click to run Adobe Flash Player". When I rightclick and choose Run this Plugin, nothing happens. I've tried to apply fixes using the Pepperflash technique, as well as the Adobe Flashplugin technique.

3

Update 2019-05-29:
This is now fixed for Chromium via chromium-browser 74.0.3729.169-0ubuntu0.19.04.1.
(Not yet for Google Chrome, though.)


Yep, it's a known bug. Someone posted the Chromium fix for Ubuntu 19.04 finally.

First, let's get a clean slate:

sudo apt-get --purge remove chromium-browser
sudo apt-get --purge remove adobe-flashplugin

Do the following to find a list of all the pepper stuff and then get rid of it with apt-get --purge remove ___package-name___

sudo apt-cache search pepper | grep -i pepper | grep -i flash

Now, visit here with Firefox (since you don't have Chromium):

https://launchpad.net/ubuntu/+source/chromium-browser/74.0.3729.131-0ubuntu1

Look for Builds. Find one that fits your architecture. Mine for instance was AMD64. I clicked that. Now, from this list, you need to download two binary packages:

chromium-codecs-ffmpeg 74.0.3729.131-0ubuntu1
chromium-browser 74.0.3729.131-0ubuntu1

(Note when you click those links above on that web page, it will take you to a page that says "Downloadable files" and will have your deb file to download.)

Once both deb files are downloaded, use the dpkg command to install, starting with the ffmpeg file first:

sudo dpkg -i chromium-codecs-ffmpeg*
sudo dpkg -i chromium-browser*

Now go into your GUI-based Apt Package Manager and look for Software Sources. Click the Other Software tab. You'll see 2 items called Canonical Partners -- click the one that is not the Source Code version and click OK or Close to enable it.

Next, at command line, do:

sudo apt-get update
sudo apt-get install adobe-flashplugin

Now launch Chromium. When viewing a Flash component your first time on a given domain, Chromium will act kind of dumb and tell you that you need to install Flash. Click the link to install Flash. It won't actually install Flash. Instead, a security prompt will appear to ask if you want to enable Flash. Do so. The page will load your Flash component. You can go to this page to test if you have Flash installed. Note if you see a puzzle piece, click it, choose Enable Flash, and you should see flash content like an ad plus a "Version Information" box appear. That means you have flash enabled.

Here's something else to note. Adobe's newer flash test page is broken when viewed from Linux Chromium. It provides the wrong answer. Instead, use the older flash test page, click the puzzle piece, enable Flash, and you'll see Flash content appear if you have done these steps properly.

  • Thanks for explaining this! However, I don't understand what you mean by "experimental". The fix has been uploaded to the development version of Ubuntu and it will soon reach 19.04, 18.10, 18.04 and 16.04 too. – Gunnar Hjalmarsson May 7 at 12:51
  • I'm just repeating that the word experimental is what is listed on the launchpad.net website for this release. I figured mods would be upset if I didn't post a disclaimer about that. – Volomike May 7 at 15:43
  • I can't find it. Can you be more specific? Asking because while disclaimers generally are good, disclaimers which are not motivated only confuse users. – Gunnar Hjalmarsson May 7 at 16:27
  • 1
    You're right. I cant find it either. It was very late when I posted this. I'll revise my post to remove the disclaimer. – Volomike May 7 at 16:29
1

Want to add a few things as a supplement to Volomike's answer.

The issue is affecting both Chromium and Google Chrome. There is an upstream commit which fixes it, and that commit has been included as a patch when building Chromium for Ubuntu eoan. It will soon be added to the Chromium build for Ubuntu 19.04 too. In the meantime, Volomike's solution works.

It will take a while before the commit gets included in Google Chrome.

The issue is related to the update of glibc from version 2.28 to 2.29, which happened in Ubuntu 19.04. Consequently Flash works as usual in previous Ubuntu releases with both Chromium and Google Chrome.

Firefox is not affected by the issue at all.

0

I had this same problem and launching chromium with the --no-sandbox switch worked for me. Do not do this permanently as it is unsafe. For a long list of other useful switches see: https://peter.sh/experiments/chromium-command-line-switches/

A safer method might be using the switch --ppapi-flash-path ⊗ Use the PPAPI (Pepper) Flash found at the given path. ↪ However I didn't try this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.