0

Sometimes, on boot, the boot resolution gets low (something arround 680x400) and after the boot I can't see the screen. Normally I solve it by reinstallng NVIDIA drivers or Loading the Default Configuration on BIOS. Sometimes it works, sometimes it does not!

This time I tried several things and I am now writting through Teamviewer on my phone.

So the computer starts but it can not show the image properly.

When I am starting the computer I already know if its gonna work or not: If the ASUS screen apears it's OK otherwise it will not show the image.

When it dows not work its shows very briefely (miliseconds) a JMICRON screen saing the driver was not find.

  • Kubuntu 18.10 - Kernel 4.18.0-18-generic
  • P67B3 motherboard with a video card NVIDIA ASUS 1060.
  • 3 HDS: 1 ext4 (boot) and 2 NTFS.

I would not like to reinstall the system. I already done it and the issue persists.

I have been having this problem for months so I dont think its kernel related. I am grateful for any help.

0

With nvidia drivers it can happen when the kernel DKMS modules are not handled properly during updates.

You can manualy trigger this via terminal using:

sudo dpkg-reconfigure nvidia-dkms-390

Then reboot.

troubleshooting

Also make sure that there is nothing like nomodeset in your /etc/default/grub

cat /etc/default/grub | grep ^GRUB_CMDLINE

It should be:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

nomodeset hunting

It's also good idea to look for it in other places:

grep nomodeset /etc/ -rs

The only place you should see it is /etc/grub.d/10_linux

GRUB_CMDLINE_LINUX_RECOVERY="$GRUB_CMDLINE_LINUX_RECOVERY nomodeset"

xorg.conf

Also if /etc/X11/xorg.conf is present you can try to rename it for the purpose of debuging:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

In case it doesn't help you can simply rename it again later on to bring back your settings:

sudo mv /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

There are also nvidia-settings and nvidia-xconfig that are worth of trying for changing stuff and recreating xorg.conf from scratch.

Here's mine, with settings that helps me work around screen tearing:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
  • Thank you. It seems it worked its been almost 10 days without the problem! – Carlos Massucci May 18 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.