1

My Samsung C410W printer worked perfectly with 18.10 (Ubuntu and Xubuntu) but now fails after upgrade to Ubuntu 19.04.

I have seen multiple different error messages when I try to print, including

SPL-C ERROR - FALSE

SPL-C ERROR - uw_color < 5

SPL-C ERROR - Insufficient Memory

My SPL-C version is 5.59 05-04-2012

The printer works perfectly from Windows 10 and if I boot to an older version of Ubuntu (e.g. 18.10)

I have tried uninstalling and re-installing the Samsung drivers uld_V1.00.39_01.17.tar.gz and uld_v1.00.36_00.91.tar.gz, but to no avail.

Any ideas?

  • Open Printer Properties on the old system and carefully note Device URI and Make and Model (these are my translations, could be slightly different). Copy them to the new system. Does that help? – Jos May 6 '19 at 20:47
  • I compared Device URI and Make and Model on new and old systems: Old URI: dnssd://Samsung%20C410%20Series%20(SEC001599ECF95E)._printer._tcp.local/ (Samsung C410 Series) New URI: socket://192.168.0.220 Samsung C410 Series. Both work in 18.10 (Xubuntu) and neither in 19.04 (Ubuntu) – badshot66 May 7 '19 at 8:47
  • I'm having the same problem, for now I'm using virtual box with ubuntu 18.04 just to print (or ask my girlfriend, she has Windows 10) – joente Aug 17 '19 at 17:38

Browse other questions tagged or ask your own question.