0

I have changed my DNS settings a few weeks back. It solved the problem and i forgot about it, but now I cant remember what changes I've done, because I've copied a few commands from askubuntu and it worked...

Now I want to flush my DNS but when I do as How can I flush the DNS on Ubuntu 17.04? I recieve this message:

sudo systemd-resolve --flush-caches

Failed to flush caches: Unit dbus-org.freedesktop.resolve1.service not found.

  1. What are the popular Ubuntu 18.04 networking providers?
  2. How do I flush my DNS and how to know its TTL or TTL of a record in it from command line?

Running: Ubuntu 18.04.2 LTS

sudo apt-get install whois
1

The main network management daemon in Ubuntu is NetworkManager.

The error you're seeing might be caused by missing symlink inside /etc/systemd/system.

Please try to recreate it by using:

sudo ln -sf /lib/systemd/system/systemd-resolved.service /etc/systemd/system/dbus-org.freedesktop.resolve1.service

If you're having issues with systemd-resolved.service you can try to restart it. It should also flush DNS caches as a result.

sudo systemctl restart systemd-resolved.service

To see the domain TTL's you can use dig from dns-utils

apt install dnsutils
dig askubuntu.com

sample output:

;; ANSWER SECTION:
askubuntu.com.      247 IN  A   151.101.1.69
askubuntu.com.      247 IN  A   151.101.65.69
askubuntu.com.      247 IN  A   151.101.129.69
askubuntu.com.      247 IN  A   151.101.193.69

247 is the current TTL

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.