1

I'm trying to run an Qtstalker installed on schroot. Steps described here: How do I install Qtstalker on Ubuntu 17.10?

When I come to the last step schroot -c precise env DISPLAY=:0.0 qtstalker I get the error:

qtstalker: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

I tried going to root schroot -c precise -u root, then tried sudo apt-get install qt3 as well as sudo apt-get install libqt-mt

Gettin the error

Unable to locate package libqt-mt

I had already added lists to sources.list in chroot as outlined in that solution.

deb http://archive.ubuntu.com/ubuntu precise main universe multiverse
deb http://security.ubuntu.com/ubuntu precise-security main restricted universe multiverse

@N0rbert

UPDATE. Downloaded https://launchpad.net/ubuntu/precise/amd64/libqt3-mt/3:3.3.8-b-8ubuntu3 and started installing on schroot with dependency and as well as debconf errors.. It even tries to remove libqt3-mt (see Bold markups please)

Any thoughts? Thanks very much again.

dpkg -i --force-all libqt3*.deb

dpkg: libqt3-mt: dependency problems, but configuring anyway as you requested: libqt3-mt depends on libaudio2; however: Package libaudio2 is not installed. libqt3-mt depends on libfontconfig1 (>= 2.8.0); however: Package libfontconfig1 is not installed. libqt3-mt depends on libfreetype6 (>= 2.2.1); however: Package libfreetype6 is not installed. libqt3-mt depends on libice6 (>= 1:1.0.0); however: Package libice6 is not installed. libqt3-mt depends on libjpeg8 (>= 8c); however: Package libjpeg8 is not installed. libqt3-mt depends on libmng1 (>= 1.0.10); however: Package libmng1 is not installed. libqt3-mt depends on libpng12-0 (>= 1.2.13-4); however: Package libpng12-0 is not installed. libqt3-mt depends on libsm6; however: Package libsm6 is not installed. libqt3-mt depends on libstdc++6 (>= 4.1.1); however: Package libstdc++6 is not installed. libqt3-mt depends on libx11-6; however: Package libx11-6 is not installed. libqt3-mt depends on libxcursor1 (>> 1.1.2); however: Package libxcursor1 is not installed. libqt3-mt depends on libxext6; however: Package libxext6 is not installed. libqt3-mt depends on libxft2 (>> 2.1.1); however: Package libxft2 is not installed. libqt3-mt depends on libxi6; however: Package libxi6 is not installed. libqt3-mt depends on libxinerama1; however: Package libxinerama1 is not installed. libqt3-mt depends on libxrandr2; however: Package libxrandr2 is not installed. libqt3-mt depends on libxrender1; however: Package libxrender1 is not installed. libqt3-mt depends on fontconfig; however: Package fontconfig is not installed. Setting up libqt3-mt (3:3.3.8-b-8ubuntu3) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place

apt-get install -f  

Reading package lists... Done Building dependency tree
Reading state information... Done Correcting dependencies... Done The following extra packages will be installed: apt-utils binutils:i386 cpp:i386 cpp-4.6:i386 debconf debconf-i18n debianutils dpkg fontconfig fontconfig-config gcc:i386 gcc-4.6:i386 libapt-inst1.4 libapt-pkg4.12 libaudio2:i386 libc-dev-bin libc6-dev:i386 libdb5.1 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexpat1 libexpat1:i386 libffi6:i386 libfontconfig1 libfontconfig1:i386 libfreetype6 libfreetype6:i386 libgcc1 libgcc1:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgmp10:i386 libgomp1:i386 libice6:i386 libjpeg-turbo8:i386 libjpeg8:i386 liblcms1:i386 libllvm3.0:i386 liblocale-gettext-perl libmng1:i386 libmpc2:i386 libmpfr4:i386 libpam-modules libpam-modules-bin libpam0g libpciaccess0:i386 libpng12-0:i386 libqt3-mt:i386 libquadmath0:i386 libsm6:i386 libstdc++6 libstdc++6:i386 libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libtinfo5 libuuid1 libuuid1:i386 libx11-6:i386 libx11-data libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxmu6:i386 libxrandr2:i386 libxrender1:i386 libxt6:i386 libxxf86vm1:i386 linux-libc-dev:i386 lsb-base manpages manpages-dev ncurses-bin passwd perl-base sed sensible-utils ttf-dejavu-core tzdata ucf uuid-runtime x11-common Suggested packages: binutils-doc:i386 cpp-doc:i386 gcc-4.6-locales:i386 debconf-doc debconf-utils whiptail dialog gnome-utils libterm-readline-gnu-perl libgtk2-perl libnet-ldap-perl libqtgui4-perl libqtcore4-perl apt gcc-multilib:i386 make:i386 manpages-dev:i386 autoconf:i386 automake1.9:i386 libtool:i386 flex:i386 bison:i386 gdb:i386 gcc-doc:i386 gcc-4.6-multilib:i386 libmudflap0-4.6-dev:i386 gcc-4.6-doc:i386 libgcc1-dbg:i386 libgomp1-dbg:i386 libquadmath0-dbg:i386 libmudflap0-dbg:i386 binutils-gold:i386 nas:i386 glibc-doc:i386 libglide3:i386 liblcms-utils:i386 libpam-doc pciutils:i386 libqt3-mt-psql:i386 libqt3-mt-mysql:i386 libqt3-mt-odbc:i386 man-browser Recommended packages: uuid-runtime:i386 The following packages will be REMOVED: libqt3-mt The following NEW packages will be installed: apt-utils binutils:i386 cpp:i386 cpp-4.6:i386 debconf debconf-i18n debianutils dpkg fontconfig fontconfig-config gcc:i386 gcc-4.6:i386 libapt-inst1.4 libapt-pkg4.12 libaudio2:i386 libc-dev-bin libc6-dev:i386 libdb5.1 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexpat1 libexpat1:i386 libffi6:i386 libfontconfig1 libfontconfig1:i386 libfreetype6 libfreetype6:i386 libgcc1 libgcc1:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgmp10:i386 libgomp1:i386 libice6:i386 libjpeg-turbo8:i386 libjpeg8:i386 liblcms1:i386 libllvm3.0:i386 liblocale-gettext-perl libmng1:i386 libmpc2:i386 libmpfr4:i386 libpam-modules libpam-modules-bin libpam0g libpciaccess0:i386 libpng12-0:i386 libqt3-mt:i386 libquadmath0:i386 libsm6:i386 libstdc++6 libstdc++6:i386 libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libtinfo5 libuuid1 libuuid1:i386 libx11-6:i386 libx11-data libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxmu6:i386 libxrandr2:i386 libxrender1:i386 libxt6:i386 libxxf86vm1:i386 linux-libc-dev:i386 lsb-base manpages manpages-dev ncurses-bin passwd perl-base sed sensible-utils ttf-dejavu-core tzdata ucf uuid-runtime x11-common 0 upgraded, 95 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. Need to get 0 B/52.0 MB of archives. After this operation, 144 MB of additional disk space will be used. Do you want to continue [Y/n]? y E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 31%E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 63%E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 94%E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 100% dpkg: regarding .../dpkg_1.16.1.2ubuntu7.7_amd64.deb containing dpkg, pre-dependency problem: dpkg pre-depends on coreutils (>= 5.93-1) coreutils is unpacked, but has never been configured. dpkg: error processing /var/cache/apt/archives/dpkg_1.16.1.2ubuntu7.7_amd64.deb (--unpack): pre-dependency problem - not installing dpkg Errors were encountered while processing: /var/cache/apt/archives/dpkg_1.16.1.2ubuntu7.7_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Tried the next in schroot:apt-get install libqt3-mt and got the below error again with dependencies.. Ubuntu suggested apt-get -f install did that and re-tried to install libqt3-mt; again the same error.

Reading package lists... Done Building dependency tree
Reading state information... Done libqt3-mt is already the newest version. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: coreutils : Depends: dpkg (>= 1.15.4) or install-info libc6 : Depends: libgcc1 but it is not going to be installed Depends: tzdata but it is not going to be installed libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed Depends: tzdata:i386 libqt3-mt : Depends: libaudio2 but it is not going to be installed Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed Depends: libfreetype6 (>= 2.2.1) but it is not going to be installed Depends: libice6 (>= 1:1.0.0) but it is not going to be installed Depends: libjpeg8 (>= 8c) but it is not going to be installed Depends: libmng1 (>= 1.0.10) but it is not going to be installed Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed Depends: libsm6 but it is not going to be installed Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed Depends: libx11-6 but it is not going to be installed Depends: libxcursor1 (> 1.1.2) but it is not going to be installed Depends: libxext6 but it is not going to be installed Depends: libxft2 (> 2.1.1) but it is not going to be installed Depends: libxi6 but it is not going to be installed Depends: libxinerama1 but it is not going to be installed Depends: libxrandr2 but it is not going to be installed Depends: libxrender1 but it is not going to be installed Depends: fontconfig Recommends: libgl1-mesa-glx or libgl1 Recommends: libglu1-mesa but it is not going to be installed or libglu1 Recommends: libxmu6 (>= 4.3.0.dfsg.1-4) but it is not going to be installed libqtstalker0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libqt3-mt:i386 (>= 3:3.3.8b) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed qtstalker:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libqt3-mt:i386 (>= 3:3.3.8b) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed Depends: libx11-6:i386 but it is not going to be installed Depends: libxext6:i386 but it is not going to be installed Recommends: qtstalker-doc:i386 (= 0.36-2) but it is not installable qtstalker-plugin-mysql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libqt3-mt:i386 (>= 3:3.3.8b) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed qtstalker-quote-plugins:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libqt3-mt:i386 (>= 3:3.3.8b) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed ta-lib0-dev:i386 : Depends: libc6-dev:i386 but it is not going to be installed or libc-dev:i386 E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Thanks again.

****Per @N0rbert's advice I reinstalled. Qtstalker launced, but crashed **** with an error in the comments at first try of data retrieval.

During the re-installation, at the last command dpkg -i --force-all *.deb to install packages. I get the following errors. Not sure what's going on, it encountered errors libqt3-mt Perhaps that's the reason...

Preparing to replace libdb4.6:i386 4.6.21-16 (using libdb4.6_4.6.21-16_i386.deb) ... Unpacking replacement libdb4.6:i386 ... Preparing to replace libmysqlclient15off:i386 5.0.92-b23.87.lenny (using libmysqlclient15off_5.0.92-b23.87.lenny_i386.deb) ... Unpacking replacement libmysqlclient15off:i386 ... Selecting previously unselected package libqt3-mt. dpkg: error processing libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb (--install): libqt3-mt: 3:3.3.8-b-8ubuntu3 (Multi-Arch: no) is not co-installable with libqt3-mt:i386 3:3.3.8-b-8ubuntu3 (Multi-Arch: no) which is currently installed Preparing to replace libqtstalker0-dev:i386 0.36-2 (using libqtstalker0-dev_0.36-2_i386.deb) ... Unpacking replacement libqtstalker0-dev:i386 ... Preparing to replace libqtstalker0:i386 0.36-2 (using libqtstalker0_0.36-2_i386.deb) ... Unpacking replacement libqtstalker0:i386 ... Preparing to replace libta-lib0:i386 0.4.0-2 (using libta-lib0_0.4.0-2_i386.deb) ... Unpacking replacement libta-lib0:i386 ... Preparing to replace qtstalker-doc 0.36-2 (using qtstalker-doc_0.36-2_all.deb) ... Unpacking replacement qtstalker-doc ... Preparing to replace qtstalker-plugin-mysql:i386 0.36.0-1 (using qtstalker-plugin-mysql_0.36.0-1_i386.deb) ... Unpacking replacement qtstalker-plugin-mysql:i386 ... Preparing to replace qtstalker-quote-plugins:i386 0.36-2 (using qtstalker-quote-plugins_0.36-2_i386.deb) ... Unpacking replacement qtstalker-quote-plugins:i386 ... Preparing to replace qtstalker:i386 0.36-2 (using qtstalker_0.36-2_i386.deb) ... Unpacking replacement qtstalker:i386 ... Preparing to replace ta-lib0-dev:i386 0.4.0-2 (using ta-lib0-dev_0.4.0-2_i386.deb) ... Unpacking replacement ta-lib0-dev:i386 ... Setting up libdb4.6:i386 (4.6.21-16) ... Setting up libmysqlclient15off:i386 (5.0.92-b23.87.lenny) ... dpkg: also configuring libqt3-mt:i386' (required bylibqtstalker0:i386') Setting up libta-lib0:i386 (0.4.0-2) ... Setting up qtstalker-doc (0.36-2) ... dpkg: also configuring libqt3-mt:i386' (required by qtstalker-plugin-mysql:i386') dpkg: also configuring libqt3-mt:i386' (required byqtstalker-quote-plugins:i386') dpkg: also configuring libqt3-mt:i386' (required byqtstalker:i386') Setting up ta-lib0-dev:i386 (0.4.0-2) ... Setting up libqt3-mt:i386 (3:3.3.8-b-8ubuntu3) ... Setting up libqtstalker0:i386 (0.36-2) ... dpkg: error processing libqt3-mt:i386 (--install): package libqt3-mt:i386 is already installed and configured Setting up qtstalker-plugin-mysql:i386 (0.36.0-1) ... dpkg: error processing libqt3-mt:i386 (--install): package libqt3-mt:i386 is already installed and configured Setting up qtstalker-quote-plugins:i386 (0.36-2) ... dpkg: error processing libqt3-mt:i386 (--install): package libqt3-mt:i386 is already installed and configured Setting up qtstalker:i386 (0.36-2) ... Setting up libqtstalker0-dev:i386 (0.36-2) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place Errors were encountered while processing: libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb libqt3-mt:i386 libqt3-mt:i386 libqt3-mt:i386

1 Answer 1

0

As far I can see:

$ apt-cache policy libqt3-mt
libqt3-mt:
  Installed: (none)   
  Candidate: 3:3.3.8-b-8ubuntu3  
  Version table:
     3:3.3.8-b-8ubuntu3 0
        990 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
     3:3.3.8-b-6ubuntu2 0
        500 http://old-releases.ubuntu.com/ubuntu/ lucid/main amd64 Packages
     3:3.3.8-b-0ubuntu3 0
        500 http://old-releases.ubuntu.com/ubuntu/ hardy/main amd64 Packages
     3:3.3.6-1ubuntu3 0
        500 http://old-releases.ubuntu.com/ubuntu/ dapper/main amd64 Packages >```

you need to install libqt3-mt package into the schroot and then proceed.

6
  • Thanks @N0rbert. I think I'm facing dependency issues. It seems like its trying to remove the libqt3-mt, and install bunch of others. I came thus far -appended to question.
    – AtaSagun
    May 8, 2019 at 4:00
  • It seems that you use wrong method of package installation. You just need simple apt-get inside schroot - schroot -c precise -u root apt-get install libqt3-mt. Your method added the problems...
    – N0rbert
    May 8, 2019 at 8:04
  • thanks. Tried this as soon as I can; got the appended response. Still giving dependency error. Should I start from scratch, what do you think?
    – AtaSagun
    May 9, 2019 at 17:29
  • I think you should start from scratch. I have tested my instruction before publishing it, so please follow it precisely. Last time I have checked it in 18.04 LTS.
    – N0rbert
    May 9, 2019 at 17:44
  • Thank you very much sir, you are a gentlemen. I got the qtstalker launch, but it crashed with Child terminated by signal ‘Segmentation fault’ message...During the reinstallation, I got error at the final dpkg. Appended the screen message with errors. Thanks again, hopefully this software pays dividend for all your efforts :)
    – AtaSagun
    May 9, 2019 at 19:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .