I know there are a lot of questions on the topic, but I think my situation is slightly different from the ones I saw. I have a brand new dell precision 3530 which came with ubuntu 18.04 LTS on a 512 GB disk. I installed one more 240 GB ssd for windows to duel-boot. I followed this guide to make a bootable win10 usb: I turned my BIOS to legacy and I booted the win10 installer.

The installation goes fine, but to end it windows needs to reboot. Here comes the problem: I'm not able to find a way to boot windows at this stage. It doesn't show up in BIOS and in grub neither. But the os sits there, in /dev/sda1 since I'm able to see the GBs occupied by it.

Here's GParted view of the HDD containing win10 after my install-attempt: enter image description here

What I tried:

  • Boot Repair output

    GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activating the [Separate /boot/efi partition:] option.

Any help would be highly appreciated since I'm quite stuck!

EDIT: I solved the problem (see answer below), but I'd like to post the BIOS screen for a working USB UEFI install: enter image description here

Corsair is the USB key, and installation started properly in UEFI mode after selection partition 1.

  • Thanks for the comment. But, I mean, my usb seems to be bootable since I'm able to start (and almost finish!) the win10 install. Am I wrong?
    – a_bet
    May 6, 2019 at 14:41
  • @PRATAP The problem and solution is identified in my answer. It was/is kinda obvious.
    – user880592
    May 6, 2019 at 15:05

1 Answer 1


Here's the problem: Legacy (why, oh why did you changed to legacy?). If you had to CHANGE then the factory installed Ubuntu was in UEFI MODE (as it should be).

I understand that if it was the other way around, installing Ubuntu after Windows, begginers my be tempted to do that because of wrong assumptions about desktop Linux or because following some old guide no longer applicable to UEFI computers. But explicitly enabling Legacy/CSM to install Windows 10? It's a textbook definition of insanity!

How to do it correctly is the enable UEFI, preferably "UEFI only", and assure the Windows USB media is booting in UEFI mode beaches how it boots is how it installs. Disabling Legacy/CSM (AKA UEFI only) is the best way to assure it boots and installs in the correct mode.

Yes, there are methods to convert Windows to a UEFI installation but at this point it's better, safer and probably faster to just reinstall Windows in the correct mode.

Warning: After the Windows installation has finalized it likely will change the UEFI boot order to "Windows bootloader manager" and boot Windows directly. Just open the UEFI settings and change it back to "Ubuntu". You will then boot Ubuntu. At this point Grub will NOT show Windows as an option. For that you need to open the terminal and run suro update-grub.

  • 1
    BIOS & UEFI Windows partitions, note system has totally different format & meaning between BIOS & UEFI msdn.microsoft.com/en-us/library/windows/hardware/… & msdn.microsoft.com/en-us/library/windows/hardware/… Microsoft has required vendors to install in UEFI mode since 2012 & Windows 8 release. Legacy mode exists so some users who had many older systems could keep same configuration.
    – oldfred
    May 6, 2019 at 15:33
  • 1
    Thanks a lot. I switched to UEFI and rebooted with the key inserted, I selected it in the BIOS and the installer started in UEFI mode (also better user interface...). Windows installed correctly and now I see it both in BIOS and GRUB. Thanks again.
    – a_bet
    May 6, 2019 at 15:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .