10

How can we disable USB autosuspend on Ubuntu 18.04 for all USB devices and/or specific ones?

Previous questions on this subject are outdated (How can I disable usb-autosuspend for a specific device? and How to disable auto power off of usb devices like usb mouse?)

Edit: This question is completely unrelated to Two USB ports stopped working because my USB ports have not stopped working completely, but apparently and momentarily suspended for just a few (mili)seconds

3
10

Update, 20201014: Just received validation (see comment from "Blackbird") that this solution continues to work in 20.04. Thanks Blackbird for the useful feedback!

This reference seems to be authoritative on disabling usb autosuspend.

Although the USB autosuspend is a feature designed to preserve battery life, its' 18.04 default is "enabled", whether or not the device Ubuntu is being installed on even has a battery.

Further, in order for autosuspend to be more help than harm, it appears that the USB device's driver needs to support autosuspend. Hence all the posts- yours' included- seeking to disable the "feature".

In 18.04 on my device, I scripted disabling autosuspend persistently in /etc/default/grub like so:

sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT="/&usbcore.autosuspend=-1 /' /etc/default/grub

update-grub

systemctl reboot

The sed expression just prepends "usbcore.autosuspend=-1" with a trailing space after the initial quote mark to ensure it always matches whatever your particular GRUB_CMDLINE_LINUX_DEFAULT options look like.

If you execute cat /sys/module/usbcore/parameters/autosuspend after a reboot, you'll remark the "-1" preference (disabled) is retained.

Anyhoo, hope this helped you out-

16
  • This simply did not work for me. My USB device (Yamaha eletric piano) still quits after about 30 seconds. The referenced article, while informative, does not make clear how to disable autosuspend altogether.
    – Paul A.
    Oct 24 '19 at 13:07
  • 1
    The fact that the piano works fine in Windows 10 (same machine) and recovers briefly after a reboot certainly indicates that the fault does not lie with the piano. I believe that autosuspend can be done selectively -- which might have something to do with the fact that the USB hard drive doesn't autosuspend but the piano apparently does. I also read somewhere that enablement of autosuspend was only recently set to default to enabled.
    – Paul A.
    Oct 26 '19 at 0:57
  • 4
    This solution also works for Ubuntu 20.04.
    – Blackbird
    Oct 14 '20 at 11:33
  • 3
    @Blackbird I updated my answer to include your feedback. Really appreciate you taking the time to provide useful feedback to improve the answer!
    – F1Linux
    Oct 14 '20 at 11:42
  • 2
    Hi @pishpish- In regards to not responding to Humpity, my answer- the only answer- to this question is GRUB specific. I made no warranties for any other configuration. Humpity wanted an answer for non-GRUB. There's nothing stopping you or somebody else adding a NEW answer for Humpity. Whenever I solve a problem for myself and I feel the solution might benefit a wider audience, I knowledge share to avoid a gazillion folks- OK, 12,000 users at time of writing- all solving the same problem individually.
    – F1Linux
    Apr 27 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.