3

I just upgraded to 19.04. I have a Brother laser printer that I've used for quite a while with 14.04 with no problems. I reinstalled the drivers, and have been using the printer in 19.04, also without problems, to print .odt, .docx, and .pdf files.

This morning I tried to print a specific pdf. Nothing seems amiss when I click print, but the file did not print. I tried other pdfs, and they work fine. I tried another pdf reader (Okular instead of Evince) and that same file will not print from Okular either. Same if I open it in Firefox.

It's not the end of the world if I can't print this one pdf on this machine, but I am very curious about what could be causing this. Any tips on how to troubleshoot, or what might cause a single pdf to not print?

  • 4
    Try this: print the pdf to a file, and choose pdf as the file format. Then print that pdf file. – Jos May 5 '19 at 17:06
  • 1
    Would it happen to be one of those fancy ones with fill-in spaces and such? Sometimes you need the official Acrobat reader to work with those.... – You'reAGitForNotUsingGit May 5 '19 at 18:26
  • @AndroidDev Nope, just simple images and text. Instructions from an auto manufacturer on how to install a part. – partial_mask May 5 '19 at 19:04
  • @Jos that's a good suggestion. I tried prints as pdf and printing the output of that, but it showed the same behavior. – partial_mask May 6 '19 at 13:04
  • a year later this is still an issue, also does not work with 18.04 – partial_mask May 24 at 3:18
1

I came across this question because I have the same issue with a specific pdf (OpenSUSE Tumbleweed, kde, Epson printer, Okular). While I still don't know why this happens, a 'Force Rasterization'in the kde print dialog, pdf options, works around the issue for me.

| improve this answer | |
1

In addition to the "Force rasterization" in Okular, you might be able to get around these unprintable PDFs by converting them to a 600 DPI .djvu file:

pdf2djvu -d 600 file.pdf > printable.djvu

or to a 600 DPI PDF 1.3 file:

ps2pdf13 -r600x600 file.pdf printable.pdf 

More details can be found at https://feeding.cloud.geek.nz/posts/printing-hard-to-print-pdfs-on-linux/.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.