0

Please tell me someone. The Internet is connected to the laptop via DSL cable connection settings. I distribute Wifi from ubuntu 19.04 by creating an access point. Messengers, YouTube, other applications work, but the pages in browsers do not open. If you turn on any vpn then the pages start to open. I tried with several smartphones and tablets, everywhere the result is the same. Where to dig I can not understand. I would be grateful for any advice. here is the output of the command

dpkg -l *dnsmasq*

+++ - ================ - ============= ============ - == ==============================
un dnsmasq <no> <no> (description not available)
ii dnsmasq-base 2.80-1ubuntu1 amd64 Small caching DNS proxy and DHCP
un dnsmasq-base-lua <no> <no> (no description available)

I get this data: $ ping -c 4 -M do -s 1472 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1472(1500) bytes of data. ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 72ms

$ ping -c 4 -M do -s 1462 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1462(1490) bytes of data. 1470 bytes from 8.8.8.8: icmp_seq=1 ttl=123 time=24.3 ms 1470 bytes from 8.8.8.8: icmp_seq=2 ttl=123 time=24.1 ms 1470 bytes from 8.8.8.8: icmp_seq=3 ttl=123 time=24.2 ms 1470 bytes from 8.8.8.8: icmp_seq=4 ttl=123 time=24.2 ms

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 8ms rtt min/avg/max/mdev = 24.137/24.194/24.266/0.119 ms

$ ping -c 4 -M do -s 1452 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1452(1480) bytes of data. 1460 bytes from 8.8.8.8: icmp_seq=1 ttl=123 time=24.2 ms 1460 bytes from 8.8.8.8: icmp_seq=2 ttl=123 time=24.2 ms 1460 bytes from 8.8.8.8: icmp_seq=3 ttl=123 time=24.2 ms 1460 bytes from 8.8.8.8: icmp_seq=4 ttl=123 time=24.2 ms

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 7ms rtt min/avg/max/mdev = 24.157/24.204/24.237/0.030 ms

$ ping -c 4 -M do -s 1453 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1453(1481) bytes of data. 1461 bytes from 8.8.8.8: icmp_seq=1 ttl=123 time=24.3 ms 1461 bytes from 8.8.8.8: icmp_seq=2 ttl=123 time=24.1 ms 1461 bytes from 8.8.8.8: icmp_seq=3 ttl=123 time=24.2 ms 1461 bytes from 8.8.8.8: icmp_seq=4 ttl=123 time=24.3 ms

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 7ms rtt min/avg/max/mdev = 24.138/24.235/24.303/0.128 ms

What should I do next? I'm new to this. Thanks for helping me

$ ping -c 4 -M do -s 1463 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1463(1491) bytes of data.

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 0 received, 100% packet loss, time 7ms

$ ping -c 4 -M do -s 1464 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1464(1492) bytes of data.

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 0 received, 100% packet loss, time 8ms

$ ping -c 4 -M do -s 1465 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 1465(1493) bytes of data. ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492 ping: local error: Message too long, mtu=1492

--- 8.8.8.8 ping statistics --- 4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 59ms

I created a DSL connection like this https://medium.com/@dineshsonachalam/creating-a-dsl-connection-on-ubuntu-18-04-1-lts-c5b7845beea0 because my save button is inactive https://i.stack.imgur.com/cEi39.png. I can not change anything

  • Edit your question and show me dpkg -l *dnsmasq*. Start comments to me with @heynnema or I may miss them. – heynnema May 5 at 18:55
  • @heynnema Hi. I tried to do what you asked – AleksandrNikolaev May 6 at 6:57
  • It looks like you already have the dnsmasq-base installed. With DSL, your MTU is probably wrong. In your Wired Connection network profile, what is your MTU set to now... probably 1500? How about the WAN setting in your router? Let me put together a quick answer on how to properly set your MTU (it probably end up being 1492). – heynnema May 6 at 15:04
0

Your problem is with the MTU setting for your DSL connection.

There's a MTU setting in Ubuntu's network configuration, and a WAN MTU setting in your router.

For DSL, a common MTU setting is 1492. Just go ahead and try this value first and see if your web sites are now accessible.

To determine the correct setting, start with all MTU settings = 1500 and VPN = off. (VPN requires different testing).

In terminal:

ping [-c count] [-M do] [-s packet_size] [host]

The options used are:

  • c count: number of times to ping
  • M hint: Select Path MTU Discovery strategy. may be either do (prohibit fragmentation, even local one), want (do PMTU discovery, fragment locally when packet size is large), or dont (do not set DF flag).
  • s packet_size: Specifies the number of data bytes to be sent.

You should always start at 1472 and work your way down by 10 each time. Once you get a reply, go up by 1 until you get a fragmented packet. Take that value (last good value) and add 28 to the value to account for the various TCP/IP headers. Eg. let's say that 1452 was the proper packet size (where you first got an ICMP reply to your ping). The actual MTU size would be 1480, which is the optimum for the network we're working with.

ping -c 4 -M do -s 1472 8.8.8.8 # this will probably show fragmentation

ping -c 4 -M do -s 1462 8.8.8.8 # may show fragmentation

ping -c 4 -M do -s 1452 8.8.8.8 # no fragmentation?

ping -c 4 -M do -s 1453 8.8.8.8 # still no fragmentation?

reference: How to determine the proper MTU size with ICMP pings

  • I did what you asked. I registered ping commands and added my own question. What should I do next? thank @heynnema – AleksandrNikolaev May 9 at 7:13
  • Do you see how 1472 failed, and 1462 worked? Now go up by 1's and try 1463, 1464, and I suspect that 1465 will fail. If that's accurate, then you take 1464+28=1492 (the correct MTU to use). Then open your Wired Connection profile and change the MTU from auto/1500 to 1492. Reboot. Retry Internet. You may also have to change the MTU setting in your router. – heynnema May 9 at 13:38
  • I created an Internet connection in this way medium.com/@dineshsonachalam/…. and now the GUI has an inactive button save it, so I can’t change the mtu. How can I do this through the terminal? – AleksandrNikolaev May 11 at 6:20
  • What final MTU value did you come up with? Is your computer connected to a router, or directly to the DSL modem? Does the router/modem already contain your DSL account username/password? What MTU is set there? Had you been using the standard ethernet "Wired Connection" network profile before? – heynnema May 11 at 13:44
  • I supplemented the question. My computer is connected to the wire. I do not have a router. Mtu presumably 1500, but I do not know how to see and change it. I have not used standard ethernet before. I just connected the wire to the computer and made the connection as written here medium.com/@dineshsonachalam/… – AleksandrNikolaev May 12 at 5:44
0

nm-connection-editor
and for the DSL/PPPOE connection, in the IPv6 settings tab, Method, select Ignore. Then sudo service network-manager restart. It only works like this for me. In Ubuntu 18.04 I didn't have to do the ignore IPv6 thing. Only in Ubuntu 16.04 I had to set the MTU to 1492, not necessary since 18.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.