2

I've been trying to get xrdp working on 18.04 for 2 days, and am about to throw in the towel. No matter what I do all I get is a green screen after trying to log into X11. If I wait long enough (10+ minutes) I get an error box that looks like this:

XRDP Error Message

I have tried:

  • installing just xrdp
  • xrdp and xorgxrdp
  • adding gnome-session to startwm.sh
  • removing everything and using the Std-Xrdp-Install-0.2.sh script
  • Making sure everything was up to date, including the distro
  • Attempting connections from Windows 10, Windows 7, and Mac RDP
  • Made sure that I am not logged into the desktop and it's not set to autologon

I'm just not sure what else to try. Most of the guides just say "install xrdp, and it works!" But it doesn't for me. This is a fresh install from ISO to bare metal. Not a VM.

Any other ideas would be appreciated.

  • To others since this is answered below: You WILL get a black or blue screen (and nothing else) under 18.04 when already logged in on the remote Ubuntu machine/VM. Make sure you are logged out completely before trying any other methods below, or elsewhere.. I made the mistake of not checking if I was logged in. – bshea Mar 26 at 16:26
2

Problem solved.. I ended up removing xorgxrdp and reinstalling it alone. I got an error about 2 package dependencies that I ended up manually installing. Once I did that, xorgxrdp installed fine and everything works perfectly.

| improve this answer | |
  • 1
    Could you elaborate how you installed xorgxrdp dependency without breaking you X system? – Mathieu Jun 6 '19 at 11:17
1

First, uninstall xorgxrdp if you haven't already. Then install the dependency using this command:

sudo apt-get install xorg-video-abi-23

Then reinstall xorgxrdp and retry the connection. Seemed to work for me after hours of trying different methods.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.