2

when i do sudo apt-get update i am getting this

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnvidia-decode-418 : Depends: libnvidia-compute-418 (= 418.56-0ubuntu1) but it is not installed
 libnvidia-decode-418:i386 : Depends: libnvidia-compute-418:i386 (= 418.56-0ubuntu1) but it is not installed
 libnvidia-gl-418 : Depends: libnvidia-compute-418 but it is not installed
 nvidia-compute-utils-418 : Depends: libnvidia-compute-418 but it is not installed
 nvidia-driver-418 : Depends: libnvidia-compute-418 (= 418.56-0ubuntu1) but it is not installed
                     Recommends: libnvidia-compute-418:i386 (= 418.56-0ubuntu1)
 nvidia-utils-418 : Depends: libnvidia-compute-418 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

when i ran sudo apt --fix-broken install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gcc-8-base:i386 gir1.2-mutter-3 libcommons-dbcp-java libcommons-pool-java libdns-export1102 libecj-java libipt2 libllvm7 libllvm7:i386
  liblouis16 libmutter-3-0 libnvidia-cfg1-410 libnvidia-common-410 libnvidia-compute-410:i386 libnvidia-decode-410:i386
  libnvidia-encode-410:i386 libnvidia-gl-410 libnvidia-ifr1-410 libopencv-core3.2 libopencv-imgproc3.2 libpoppler79 libtbb2 libtomcat8-java
  libx264-152 libx265-160 linux-headers-4.18.0-17 linux-headers-4.18.0-17-generic linux-image-4.18.0-17-generic linux-modules-4.18.0-17-generic
  linux-modules-extra-4.18.0-17-generic nvidia-compute-utils-410 nvidia-dkms-410 nvidia-kernel-common-410 nvidia-kernel-source-410
  nvidia-utils-410 xserver-xorg-video-nvidia-410
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libnvidia-compute-410:i386 libnvidia-compute-418 libnvidia-compute-418:i386
The following NEW packages will be installed:
  libnvidia-compute-418 libnvidia-compute-418:i386
The following packages will be upgraded:
  libnvidia-compute-410:i386
1 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
16 not fully installed or removed.
Need to get 0 B/40.1 MB of archives.
After this operation, 102 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-410_418.56-0ubuntu1_i386.deb (--unpack):
 package libnvidia-compute-410:i386 (418.56-0ubuntu1) with field 'Multi-Arch: no' is not co-installable with libnvidia-compute-410 which has multiple installed instances
dpkg: regarding .../libnvidia-compute-418_418.56-0ubuntu1_i386.deb containing libnvidia-compute-418:i386:
 libnvidia-compute-418:i386 conflicts with libcuda-10.0-1
  libnvidia-compute-410:i386 provides libcuda-10.0-1 and is present and installed.

dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-418_418.56-0ubuntu1_i386.deb (--unpack):
 conflicting packages - not installing libnvidia-compute-418:i386
dpkg: regarding .../libnvidia-compute-418_418.56-0ubuntu1_amd64.deb containing libnvidia-compute-418:amd64:
 libnvidia-compute-418 conflicts with libcuda-10.0-1
  libnvidia-compute-410:i386 provides libcuda-10.0-1 and is present and installed.

dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-418_418.56-0ubuntu1_amd64.deb (--unpack):
 conflicting packages - not installing libnvidia-compute-418:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libnvidia-compute-410_418.56-0ubuntu1_i386.deb
 /var/cache/apt/archives/libnvidia-compute-418_418.56-0ubuntu1_i386.deb
 /var/cache/apt/archives/libnvidia-compute-418_418.56-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

searched for ways to remove libcuda, didnt work

not sure what to do next

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.