5

When I try to install Telegram, I get the following error:

itsmarttricks@mangesh:~$ sudo apt-get install telegram
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:6.2.2) but it is not going to be installed
 libreoffice-java-common : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-report-builder : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-script-provider-js : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-script-provider-python : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-style-colibre : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-style-elementary : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
 libreoffice-style-tango : Depends: libreoffice-common (= 1:6.2.2-0ubuntu0.18.04.1~lo1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  • Try sudo apt --fix-broken install – N0rbert May 5 at 9:05
  • This doesn't directly answer your issue, but for common programs that are outside of default repositories, a simple way is via the Ubuntu-MATE Software Boutique (refer to my answer in askubuntu.com/questions/1058304/… for how). It can be used on any Ubuntu flavor (not just mate). – guiverc May 5 at 12:07
  • 2
    @ShadowWizard this type of complaint is better used in custom flags instead of public comments. Please flag cases such as this accordingly, rather than posting comments here. – Thomas Ward May 5 at 15:32
1

It looks like you've got LibreOffice installed, but somehow managed to break its installation. To fix it, try:

sudo apt-mark auto libreoffice-common

If you've got an old version of apt-get (before 11.something, I think – well before Ubuntu 18.04's version) and this doesn't work, try instead:

sudo apt-get markauto libreoffice-common

and then update your package manager immediately.

After running one of these commands, run:

sudo apt install

(I think.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.