3

I am currently using Ubuntu 18.04, but my wireless connection stops working from time to time. Sometimes it works fine the whole day. However, other days it just keeps disconnecting, so I have to manually reconnect each time.

At times it just stops working completely and the wifi card does not even get recognized anymore. My only way to get it back working then, is to reboot.

$ lspci -nnk | grep 0280 -A3 
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
    Subsystem: Lite-On Communications Inc QCA9377 802.11ac Wireless Network Adapter [11ad:08a6]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

Is there some way to fix this? Do I need to install additional drivers or replace some?

1
  • Related questions: 1, 2, 3
    – csha
    Commented Aug 11, 2021 at 21:35

3 Answers 3

1

I was able to solve the problem of instability by entering the router settings and changing the Bandwidth from 20/40 to 20, considering that my router only supports 2.4GHz, if your router is 5ghz I think it should be better to set to 40 instead of 20.

I'm still looking for a solution to the problem of not recognizing the wifi card, but for now I can only solve by restarting too..

good luck!

1
  • This answer gives the helpful hint that this Qualcomm wireless card has flaky switching between 2.4 and 5 GHz bands. I have a similar problem with this wireless card on Windows, and changing the driver settings to prefer the 5 GHz band mostly eliminates the problem. Commented Oct 8, 2022 at 7:31
0

On elementary OS 6, based on Ubuntu 20.04.2 with kernel version 5.11.0-25-generic, the following worked for me:

sudo mv /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin.old

Based on this answer. If it does not work for you, you can revert the change by renaming firmware-6.bin.old back to firmware-6.bin.

0

First Method:

sudo apt update && sudo apt upgrade
sudo apt install --reinstall linux-firmware

2nd Method

(this method solved my issue)

sudo apt remove broadcom-sta-dkms bcmwl-kernel-source 
sudo apt install firmware-b43-installer

3rd Method:

sudo apt update && sudo apt upgrade

sudo apt install fwupd

sudo fwupdmgr refresh && sudo fwupdmgr update

sudo reboot

4th Method :

After few days of testing, it looks like a firmware problem to me. I've tested all the ones available at https://github.com/kvalo/ath10k-firmware/tree/master/QCA9377/hw1.0 and I experienced the very same issue with all the three API6 files (i.e. firmware-6.bin_*).

The latest (in terms of release date) API5 file firmware-5.bin_WLAN.TF.1.0-00023-QCATFSWPZ-1 seemed to work much better but I still experienced the issue after few solid hours.

Eventually, the file firmware-5.bin_CNSS.TF.1.0-00267-QCATFSWPZ-1 seems to be the most stable on my Lenovo Ideapad 320 using:

Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

So try renaming the existing firmware-5.bin and firmware-6.bin files under /lib/firmware/ath10k/QCA9377/hw1.0/ and use the firmware version I've mentioned. In other words...

 cd /lib/firmware/ath10k/QCA9377/hw1.0/
sudo mv firmware-5.bin firmware-5.bin.orig
sudo mv firmware-6.bin firmware-6.bin.orig
 sudo wget "https://github.com/kvalo/ath10k-firmware/blob/master/QCA9377/hw1.0/CNSS.TF.1.0/firmware-5.bin_CNSS.TF.1.0-00267-QCATFSWPZ-1?raw=true" -O firmware-5.bin

Now load the new firmware and double-check

 sudo modprobe -r ath10k_pci
 sudo modprobe ath10k_pci
 sudo dmesg | grep ath10k

output:

ath10k_pci 0000:01:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
ath10k_pci 0000:01:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
ath10k_pci 0000:01:00.0: firmware ver CNSS.TF.1.0-00267-QCATFSWPZ-1 api 5 features ignore-otp crc32 d6b81b3c
ath10k_pci 0000:01:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
ath10k_pci 0000:01:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1

Make sure the version id just next to firmware ver matches.

I hope this trick will solve that annoying issue for you too ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .