17

This morning I woke up to:

Extensions disabled

and the FireFox help page doesn't really help...

Help! What should I do now???
I need NoScript and AdBlock Plus to improve my surfing speed!!!
0:-)

  • this error is fixed now.addons are now avaliable and functioning. – trond hansen May 4 at 15:30
  • 1
    @trondhansen for some people it only cropped up recently while for others it's been resolved. – Fabby May 4 at 21:15
  • a fix is released and will be rolled out over the next few hours,for firefox on android an update is needed but it is on its way right now. – trond hansen May 5 at 4:19
  • 1
    This was bug-related and should be closed now. – Fabby Sep 15 at 16:12
6

Firefox 66.0.5 has now been released by Mozilla which avoids the Master Password issue in 66.0.4 which prevented the previous fix from working in some cases.

After the update arrives in the Ubuntu repositories, anyone who has used the workaround and disabled extension signing in about:config should re-enable it by double-clicking on the:

  • xpinstall.signatures.required and
  • extenstions.langpacks.signatures.required

settings again to set them back to the default value of true.

More Mozilla support information here.


Obsolete now:

Firefox 66.0.4 has been released by Mozilla which should fix this without requiring the Studies functionality and is now in the package repositories for all supported branches of Ubuntu.

  • @Fabby: 66.0.4 is now in the package repositories for all supported branches of Ubuntu. 66.0.5 will presumably also appear soon as it is already showing in Eoan (but 66.0.4 should fix the issue for the majority of users). – djcater May 8 at 21:54
  • apt list --upgradable Listing... Done firefox/xenial-updates,xenial-security 66.0.4+build3-0ubuntu0.16.04.1 amd64 [upgradable from: 66.0.3+build1-0ubuntu0.16.04.1] Changing acceptance. – Fabby May 9 at 6:54
18

This workaround is now obsolete.

Please use the the official method to get rid of this issue...

Just open a new tab and go to about:config and filter on signatures.required and double click both of them to turn them from true to false:

Nasty Red

and the nasty red turns into a fine yellow:

Nice Yellow

Which allows me to move on for the moment, until:

Not the answer you're looking for? Browse other questions tagged or ask your own question.