0

I hibernated my laptop a few times.

I closed the lid and reopened it.

This is what happened:

Empty Terminal

I cannot see anything but I can enter commands.

This is the nautilus window:

Empty nautilus window

How can I fix this problem without any reboot, logout or anything that leads closing the currently open application?

I welcome any terminal command.

  • Have you tried a clean reboot or shut down and back on? Hibernate on many devices isn't well supported on Linux... – Zanna May 4 '19 at 2:39
  • @Zanna, If I reboot or unity --replace, I am sure the problem will be solved. But, I do not want killing the currently open applications. – twist May 4 '19 at 2:42
  • I am sure this problem happens to others too. I has happened to me several times. I am curious how to fix it. I cannot reproduce this problem often. If you know the solution, please suggest me ASAP before I restart and loose the chance to verify if your method works. – twist May 4 '19 at 3:11
0

This is a known bug with Ubuntu 16.04. One possible fix seems to be upgrading to kernel 4.8 or higher. You can attempt to update your current kernel by running the command:

sudo apt install linux-generic-hwe-16.04
  • Many thanks, does it require rebooting? – twist May 4 '19 at 5:10
  • It may require a reboot once after the new kernel is installed, but the fix (if it works) should be permanent. – john kieran May 4 '19 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.