1

I just upgraded my distribution to 19.04 – things apparently went well except I got a message that 'install-info' couldn't be updated. This message I have ignored so far. It seemed OK until I restarted the system and tried to log in. Now it won't accept my password any more and after maybe 10 seconds I end up at the login question again. And again. I know the password is still there, since logging in via ssh from another computer works like a charm. It is also NOT a capslock problem, I have tried enough times to eliminate that. Since I have an ssh connection, I can reproduce any log or system files if someone asks me.

But I'm flabbergasted - what on earth is the problem here? I have always upgraded as soon as a new Ubuntu has been out, but this is the first time I experience problems with it.

A little update: I just tried to reboot the machine via the ssh connection, and now the screen just shows the ubuntu logo with the five blinking dots under it. Nothing has happened for half an hour now, so I guess it's really stuck there. Seems serious this - is there anyone here who understands and possibly can assist me a bit?

Update again 13may19! I just upgraded my third (old-ish) laptop to Ubuntu 19.04, and couldn't log in there either. A bit of research showed that the problem was incompatible Gnome shell extensions. I insist on the Gnome shell (gives me the desktop I want), and disabling these extensions one-by-one finally gave me a working system. Learning? Yes indeed! This was a long process, and I'm happy I'm finally there!

  • So basicly you're able to log in via SSH, but you can't log in through display manager? If so, please run sudo dpkg --configure -a to make sure that upgrade was not interrupted. Also please add output from these commands to your question: sudo apt update && sudo apt list --upgradable`` and lspci -v | grep VGA` – Comar May 3 '19 at 23:28
  • How old is this computer? Desktop or laptop? Intel video card? – heynnema May 3 '19 at 23:36
  • I still don't fully comprehend how to use askubuntu correctly, but I'm doing my best. This is an acer Aspire F15 laptop, a couple of years old. Intel Iris graphics 550, 8GB DDR4 it says on the badge. I'll attempt the suggestions from @Comar in a few minutes, and hope this will be fixed soon-ish. A lovely community this, thank you all! – Bernt Ribbum May 4 '19 at 9:39
  • code Sat 11:54 bernt@sara: ~$ sudo apt update && sudo apt list --upgradable [...] All packages are up-to-date. Listing... Done code Sat 11:56 bernt@sara: ~$ lspci -v | grep VGA 00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 550 (rev 0a) (prog-if 00 [VGA controller]) – Bernt Ribbum May 4 '19 at 10:11
  • You might try my answer and see if it helps. Report back. Start comments to me with @heynnema or I may miss them. – heynnema May 4 '19 at 13:14
0

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access

type:

sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Then reboot.

0

I had the same problem with Ubuntu version 19.04. Could not log in with my correct password. The solution was, that the root passwort evidently uses the native US keybord layout and not the keybord layout of the installation language. At the moment I have no idea, how fix the Problem. But password character input as US layout works...

0

Thanks for all suggestions! Being a bit lazy I went for the easiest solution: brand new PC with modern GPU. I'm sure this could have been fixed also on the older HW, but I lack the energy to try. Happy now with a flawless Ubuntu 19.04 on new HW, and 18.10 on the old one. They happily coexist on my local WiFi, and I'll leave it that way for now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.