2

I'd like to use the fc command. However when I type fc in bash I get

Command 'iv' not found, but can be installed with:

sudo apt install openimageio-tools

That is weird because I didn't even type iv. Furthermore the suggested package seems to be an image processing library which is far from what I want.

What is going on here and how can I use fc?

Edit:

$ type -a fc
fc is a shell builtin

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"

$ bash --version 
GNU bash, version 4.4.19(1)-release (x86_64-pc-linux-gnu)
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is free software; you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
6
  • 3
    What is the output of type -a fc? May 3, 2019 at 21:39
  • @dessert Same result as fc: Command iv not found.
    – jederik
    May 6, 2019 at 17:37
  • @dessert No alias is configured for fc by the way.
    – jederik
    May 6, 2019 at 17:39
  • Try starting bash without rc file, there's an option for that: bash --no-rc --no-profile. Sorry cannot do code highlighting at the moment but you get the idea May 6, 2019 at 18:03
  • 2
    @SergiyKolodyazhnyy That helped. Turned out that I had a typo in my .bashrc: EDITOR=iv. facepalm
    – jederik
    May 6, 2019 at 23:16

1 Answer 1

2

Turned out I had a typo in my .bashrc.

It had

EDITOR=iv

in it (instead of EDITOR=vi), so fc tried to edit my last command via the iv command. Hence the error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.