8

In Ubuntu 19.04, how can I make it to where the desktop doesn't try to mirror the desktop folder? I don't want to see any icons on my desktop.

I'm not sure how this is suppose to be by default, but my desktop shows a trash bin, a folder with my user name, and a file I put into /home/username/Desktop. Instead I would like it to show nothing.

I have nemo installed, and I can't tell whether nemo or nautilus is responsible for this, but I'm unable to find settings in either that would remove all desktop icons.

9
  • Neither file manager is responsible. Now it's done by Gnome (new feature).
    – user880592
    May 3 '19 at 13:51
  • I see. That's a sensible default. Is it optional? May 3 '19 at 13:52
  • 1
    Isn't that handled by a Gnome extension nowadays ? Go to extensions.gnome.org, choose Installed extensions, and find Desktop Icons .. and disable it.
    – Soren A
    May 3 '19 at 13:58
  • 1
    Use the Tweaks application to disable the desktop icons GNOME extension then.
    – heynnema
    May 3 '19 at 14:27
  • 1
    I think you can do it with gnome-tweak. Can't confirm right now because I'm in a tablet (Android).
    – user880592
    May 3 '19 at 14:28
4

This method worked for me:

sudo dpkg -r --force-depends gnome-shell-extension-desktop-icons

This will force removal extension, but updating the system will reinstall it and you will have to remove it again. Holding it with sudo apt-mark hold gnome-shell-extension-desktop-icons seems to prevent updates from installing.

1
  • Weird thing for me is that if that extension is installed, whether as the deb or locally, I get desktop icons, even if it's apparently disabled. Doing what you suggest (and removing the local copy I had from before) was required to get rid of them. PS. how to reverse what you did with the dpkg / apt-mark commands if I don't like it ? Aug 3 '19 at 6:46
3

Either go to here to turn off the Desktop Icons GNOME Shell extension, or use the Tweaks application to do the same thing.

Click on the gear (settings) icon to change the settings for select desktop icons.

4
  • 4
    Tweaks worked. Note: The feature was already turned off, but hitting the gear icon next to the on/off switch allowed me to remove trash-icon and the user-folder icon. May 3 '19 at 15:08
  • 2
    None of these seem to be working for me... The feature was already turned off. I've also tried the 'dpkg -r --force-depends gnome-shell-extension-desktop-icons' method below and I still have icons. Anyone have any ideas? Fresh install of 19.04.
    – corey_s
    Aug 14 '19 at 2:23
  • @corey_s did you turn off the trash and home icons in the Desktop Icons settings panel?
    – heynnema
    Aug 14 '19 at 2:45
  • Yes... Eventually just gave up and decided it wasn't worth the effort. Installed Mint instead -- problem resolved.
    – corey_s
    Aug 14 '19 at 16:53
1

This worked for me by Patrick Dark

To remove the home icon and trash icon execute these two commands in a terminal:

gsettings set org.gnome.shell.extensions.desktop-icons show-home false
gsettings set org.gnome.shell.extensions.desktop-icons show-trash false

That's all.

I hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.