0

I have wordpress installed on ubuntu 18.04.2 LTS. My Curl version is curl 7.58.0

when I enable the WooCommerce PayPal Checkout Gateway I get error message. "WooCommerce Gateway PayPal Checkout requires cURL to be installed on your server".

Any help on how I can get woocommerce to detect curl?

  • Maybe you need the curl PHP extension (package php-curl). – fkraiem May 3 at 11:02
  • I tried : sudo add-apt-repository ppa:ondrej/php sudo apt update sudo apt install php7.2-fpm php7.2-gd php7.2-curl php7.2-mysql php7.2-dev php7.2-cli php7.2-common php7.2-mbstring php7.2-intl php7.2-zip php7.2-bcmath but it didn't work – Tom Must May 3 at 11:55
  • @TomMust I am experiencing the same exact problem. I have the same versions! – Crimbo Jun 7 at 7:39
0

It sounds like you installed curl but not php-curl. Use apt to install it:

sudo apt install php-curl

Then restart apache:

systemctl restart apache2

...and you should be good to go.

  • I tried that but i'm still getting the "WooCommerce Gateway PayPal Checkout requires cURL to be installed on your server" message – Tom Must May 3 at 12:00
  • Which version of PHP does the site use? Could it be that you installed php-curl for a different PHP version?As a test, can you run PHP in REPL mode (command line mode) from a terminal (php -a). Also check php version from command line: php -v. – Eric Mintz May 4 at 10:53
  • I'm running: PHP 7.3.5-1+ubuntu18.04.1, so I don't think that's the problem – Tom Must May 6 at 7:02
  • @EricMintz Same here! – Crimbo Jun 7 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.