16

I am adding the printer from the windows network via samba.

All seems fine: - I can authenticate the access to the domain, - I can see all the printers there. - Adding ppa file, which I download from the printer manufacturer website

But I stuck in the last point when I click apply button and see another authentication window which asks just Username and Password (without domain). enter image description here

I tried everything and nothing works:

  1. Adjust smbd config to have by default the domain name, which I need
  2. {user}@{domain}
  3. {user}/{domain}
  4. {domain}/{user}
  5. {user}

Access to cups server works on localhost:631.

2

2 Answers 2

17

In Ubuntu 19.10 a new problem arises with the previous solution stated, where there is no longer a password being requested but the window freezes.

After digging around I found this solution: https://unix.stackexchange.com/a/513983/386631

Taking from the answer:

  1. Open the file /etc/cups/cups-files.conf.
  2. Find the group name at the line containing SystemGroup (in Ubuntu it should be lpadmin).
  3. Add yourself to that group (sudo usermod -a -G lpadmin your-username)
  4. Apply it (sudo service cups restart).

There will still be an authentication dialog, but now if you put your PC's username and password it works.

4
  • 1
    This also works in 20.04. Authentication dialog no longer pops up after signing out of desktop environment and signing back in. May 20, 2020 at 17:37
  • 1
    Note that for me, on 20.04, this was the solution but the accepted answer also caused no harm. i.e. I didn't need to change the DefaultAuthValue back for it to work.
    – robomc
    Jul 30, 2020 at 2:20
  • 1
    Adding user to lpadmin did the trick on Ubuntu 20.10, thanks!
    – Wirone
    Apr 8, 2021 at 9:02
  • This also works in 22.04. I used original setting "DefaultAuthType Basic" in /etc/cups/cupsd.conf
    – dbdq
    Nov 2, 2022 at 16:05
14

OK, I figure out, that this is the request of a CUPS server authentication, which by default, has a value basic in config. And you have to switch it off by doing the following:

  1. sudo nano /etc/cups/cupsd.conf
  2. change the value DefaultAuthType to None
  3. sudo service cups restart

No authentication required anymore

8
  • 2
    3. should read sudo service cups restart... no s at the end of service
    – 0x539
    Oct 15, 2019 at 20:49
  • Good suggestion 0x539. I edited the answer. Dec 15, 2019 at 19:58
  • 1
    Even after following these steps and restarting the system, I keep receiving an authentication error when trying to print (a test page). Any suggestions?
    – poomerang
    Apr 24, 2020 at 12:28
  • @poomerang hello. This answer resolves the authentication dialog problem. Apr 26, 2020 at 18:45
  • 1
    Its almost like you need a advanced degree to add a printer.
    – Mark
    Jan 31, 2022 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .