0

So I upgraded to ubuntu 19.04 today and things have not been OK. First of all the boot menu comes up when I boot, but after that things go fine through the login screen. The problem is the desktop. (I tried the older kernel but no good) Nautilus doesn’t open at all. Other apps I tried work fine. But after like 30 sec of use the desktop starts freezing. First the windows come out of focus and the keyboard doesn’t respond. Than the mouse starts to lag until it stops responding. Also conky manager does this wierd graphical glitch. What can i do to troubleshoot this? Can i check if the upgrade files are installed correctly?

UPDATE:

After some monitoring of system resources and disabling swap the last entry on the process list before the freeze was tracker-extract and a massive jump in memory usage following it. What is this process for and what can i do about it?

UPDATE 2:

krisi@krisi-HP-250-G6-Notebook-PC:~$ free -h total used free shared buff/cache available Mem: 3.8Gi 1.5Gi 774Mi 129Mi 1.5Gi 1.9Gi Swap: 2.0Gi 0B 2.0Gi krisi@krisi-HP-250-G6-Notebook-PC:~$ ls -al ~/.local/share/gnome-shell/extensions total 16 drwxrwxr-x 4 krisi krisi 4096 May 2 19:47 . drwx------ 3 krisi krisi 4096 May 2 21:51 .. drwxrwxr-x 4 krisi krisi 4096 May 2 17:48 appfolders-manager@maestroschan.fr drwxrwxr-x 4 krisi krisi 4096 May 2 19:47 netspeed@hedayaty.gmail.com

  • You probably have a GNOME extension problem. Temporarily disable ALL added extensions except the standard Ubuntu Indicators and Ubuntu Dock, then restart GNOME Shell, or log out/in. See if Nautilus/etc work better. If so, we'll troubleshoot further after you report back. (Also, re-enable swap.). Tracker runs after first 19.04 boot, to index your disk to make searches faster. – heynnema May 2 at 18:01
  • Tried that still it froze after I ran tracker daemon -s (as I had terminated that sooner) When they are disabled everything works fine. There is some sort of bug , some memory leak, because i noticed that ram went up 100% and swap was going for 50% before system monitor failed. Since I don’t really need them I thought I could delete it but it turn out it’s connected to nautilus. And I don’t want to remove nautilus too ... – kris gjika May 2 at 19:06
  • Your comment was a little unclear. Are you saying that it ran fine/better with GNOME extensions disabled? What is "system monitor failed"? Let tracker run until it's done. – heynnema May 2 at 19:14
  • Sorry if i was unclear. I was saying that disabling extensions made no difference as the system still froze. “Let the tracker run untill it’s done” - are you sure ? Some small software isn’t supposed to make the system unusable no matter what is it doing. – kris gjika May 2 at 19:20
  • You may have more than one problem. Edit your question and show me free -h and ls -al ~/.local/share/gnome-shell/extensions. – heynnema May 2 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.