I'm having trouble connecting to Steam servers and CS:GO servers on ubuntu 18.04 64-bit. Other computers on my network can connect fine, so I assume the problem is with Ubuntu. Upon launching Steam, I get a connection error where I can elect to retry connecting. If I press it, I go back to the same screen. After doing this enough times, typically 3, Steam finally connects and I can use it as normal.

When I launch CS:GO, an error message pops up saying Steam was unable to sync my files with the Steam Cloud. The game still functions when playing with bots, but matchmaking fails to reach any official CS:GO servers.

Steps I've taken:

  • check if steam/csgo servers are online (they are)
  • disabling ufw
  • reinstall steam
  • reinstall CS:GO
  • update router firmware
  • forwarding ports in my router settings
    • TCP 80, 443, 27015-27030; UDP 27000-27100, 4380
  • installing libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
  • deleting steam config files
  • verifying game cache
  • running sudo apt-get update and sudo apt-get dist-upgrade

terminal output on first launch:

Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2019-05-02 18:06:03] Startup - updater built Apr 29 2019 20:58:13
opensslconnection.cpp (1490) : Assertion Failed: unable to load trusted SSL root certificates
[2019-05-02 18:06:03] Verifying installation...
[2019-05-02 18:06:04] Verification complete
Fatal : VkResult is "ERROR_INITIALIZATION_FAILED" in /home/pgriffais/src/Vulkan/base/vulkanexamplebase.cpp at line 823

(I initially included the terminal log after launching CS:GO but askubuntu says it "looks like spam". The log included a lot of errors saying "failed to dlopen" and ended with "loading serverbrowser_client.so")

CS:GO's console just says "Ping measurement has been active for 5.0s. Sending what we have to GC" when I try to matchmake.

So what are the steps to fixing this? Is there something wrong with my network settings?


Apologies for the hasty post. It seems the issue was with SSL certificates as suggested by the log. Fixed by inserting sudo apt-get install --reinstall ca-certificates into the terminal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.