I use Lubuntu 19.04 with LXQT on a notebook with a 15-inch display and a Full HD (1920x1080 px) resolution. I set the scaling of the display to 120 by .Xresources file in the Home directory. The cursor is not terribly small, but it's size is still annoyingly smaller than what I use in Windows.

Under the LXDE desktop environment I had a way to manage the size of the mouse cursor, but now - not. I have tried my old methods plus a couple of others already with no success yet.

So I just would like to know if there exists any way to manage it's size. I think it is logical such a way to exist, since we can see that the cursor appears in a certain size anyway - this should mean that there is a setting for that somewhere.


Not from the desktop as themes do not support multiple sizes yet. There is a workaround it seems:

From the comment by sroracle to the bug report:

As a workaround, setting the XCURSOR_SIZE environment variable works. It should be noted that the Xcursor.size resource in ~/.Xresources or similar is ignored however. This issue should be looked at as out-of-box behavior on HiDPI systems is to have the cursor as small as possible.

  • 1
    Going to Session Settings and adding the environment variable XCURSOR_SIZE (with a value of 60 in my case) is indeed an easy workaround for adjusting the size of the cursor in Lubuntu with LXQT for now. Thanks :)
    – user186598
    May 2 '19 at 13:18
  • 1
    This worked for me in Lubuntu 19.04 with the LXQt 0.14.1 desktop. Preferences > LXQt settings > Session Settings. Clicked to highlight Environment. Clicked the Add button for a new Environment Variable. Double-clicked in the highlighted bar to add a Variable Name, XCURSOR_SIZE, then double-clicked the highlighted bar again under Value to type in a number. I too, used the value of 60. Rebooted. Now I can see my mouse cursor.
    – Charles
    May 4 '20 at 9:14
  • This worked for me on Lubuntu 21.10 with LXQt 0.17.0 Dec 31 '21 at 20:31

Through the usual GUI, then no—probably not yet because the LXQT team has not added this feature. There is already someone reported this issue on their GitHub page https://github.com/lxqt/lxqt/issues/953.

@comodoro This is a valid feature request and is marked as so. No option for changing the cursor size exists in LXQt settings yet but there are other ways to do so; for example, see https://wiki.archlinux.org/index.php/Cursor_themes

For the meantime you can either download large mouse cursor to substitute it, or do it yourself—here is an example of someone who trying to accomplish same thing as you → https://forum.artixlinux.org/index.php/topic,847.0.html.


As mentioned by others, the current way to do with on LXQT is with XCURSOR_SIZE. It's kinda documented here: https://manual.lubuntu.me/3/3.2/3.2.13/session_settings.html

Use your browser search for "XCURSOR_SIZE"


Open the following file with a text editor (gedit).


Add Cursor_size=(size of cursor)-eg. 38 in the Mouse section as shown on line 6.


run the following in terminal

$ sudo update-grub


The cursor size will change to your specs. once lubuntu 20.04 has opened up to the home/Desktop screen


1 [General]

2 userfile__=true

3 4 [Mouse]

5 cursor_theme=Breeze_Snow

6 cursor_size=38

  • I followed these steps on Lubuntu 21.10 and the cursor was not at the size I specified (60) when I rebooted. Dec 31 '21 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy