2

Brace for some pictures.. I'm installing "ubuntu server" using ipxe and I noticed that none of my short names work but the Fully Qaulified Domain Names (FQDN) do; the exact image being installed is as follows:

[root@repo 18.04]# md5sum ./ubuntu-18.04.2-server-amd64.iso
34416ff83179728d54583bf3f18d42d2  ./ubuntu-18.04.2-server-amd64.iso

Being that this is ipxe, I can't do a simple copy and paste which is the reason for the many pictures. I ran into the problem while attempting to get a preconfigure file to perform an automated installation of ubuntu. See the following error: enter image description here The preconfigure file is passed in through the kernel parameters in an ipxe script like so:

set theKernelParams auto=true fb=false  interface=auto priority=critical url=ipxe/ubuntuks.conf

However, this results in an error explaining that we cannot reach the server "ipxe". This is obviously not true from any machine in the lab and even not true from any other operating system that I use ipxe to install.

Further investigation and looking at the console, it would appear that ubuntu is not respecting the dhcp provided domain-name when performing name lookups. This can be seen in the resolve.conf file and the lease made by dhclient. After returning an address, dhclient should update the resolve.conf file to allow lookup of names that are not using the FQDN. screenshot: bad resolve.conf settings

After correcting the resolve.conf: good resolve.conf settings

Proof that ping works with short names after fixing the resolve.conf:

enter image description here

After making the change to the resolve.conf file.. Setup continues with the preconfigure file like nothing ever happended..

  1. This is obviously a bug that needs to be fixed for the people like me that rely on network installs. How do I file this as a bug?
  2. To follow the user docs on filing a bug, is there something that I missed to allow the installer to use the domain name while looking up addresses?
  3. What do I need to do to make sure that this bug gets attention since it clearly needs to be addressed and resolved in the fastest fashion possible?

Note: after install resolve.conf shows the following. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.