2

When clicking the "Restart" or "Power Off" buttons in Ubuntu 18.04, nothing happens.

No applications are closed, it doesn't attempt to restart or power off, it just closes the shutdown menu and that's it.

The shutdown menu also has a 60 second timer after which the system is supposed to shut down. It doesn't; once again, nothing happens.

I've been having to restart/shutdown using terminal commands, which is not my preference.

Things to note:

  • I don't believe these buttons ever worked on this system (a Dell Precision laptop). I think it's been broken like this since I installed Ubuntu in early January.
  • I have GNOME Shell Extensions installed, with 3 extensions. Problem exists still after disabling the extensions.
  • I've tried "Ubuntu" and "Ubuntu with Wayland" from the login screen. Those are the two options available.
  • Kernel version: 4.15.0-47-generic

Power Off Menu

About

3
  • 1
    Is this a new install or an existing install where this feature just stopped working? Can you tell us a little more about your system? It is hard to troubleshoot the issue without a little more context.
    – RaidPinata
    Commented May 1, 2019 at 18:53
  • Added an extra bullet point and a screenshot of some basic system info. Let me know if there is any other info or logs I could provide. Commented May 1, 2019 at 22:02
  • I just tried tailing /var/log/syslog while opening the shutdown menu. I saw this warning: [/home/<user>/.local/share/gnome-shell/extensions/suspend-button@laserb/extension.js 191]: assignment to undeclared variable gnomeShellVersion. (I have an extension that adds a suspend button). Then I tried the restart button and it worked. Then it worked a second time. Seems to maybe be a sporadic issue. I think I will have to just keep monitoring the syslog and trying again and see what the syslog prints next time it fails to work. Commented May 1, 2019 at 22:38

0

You must log in to answer this question.

Browse other questions tagged .