0

I'm doing phpservermonitor's setup, I finished everything and supposedly it should be ready, but I get an error when I access

http://my_localhost/phpservermon

The error is

Fatal error: Uncaught Error: Class 'DOMDocument' not found in /var/www/html/phpservermon/vendor/symfony/config/Util/XmlUtils.php:52 Stack trace: #0 /var/www/html/phpservermon/vendor/symfony/dependency-injection/Loader/XmlFileLoader.php(280): Symfony\Component\Config\Util\XmlUtils::loadFile('/var/www/html/p...', Array) #1 /var/www/html/phpservermon/vendor/symfony/dependency-injection/Loader/XmlFileLoader.php(41): Symfony\Component\DependencyInjection\Loader\XmlFileLoader->parseFileToDOM('/var/www/html/p...') #2 /var/www/html/phpservermon/src/psm/Router.php(201): Symfony\Component\DependencyInjection\Loader\XmlFileLoader->load('services.xml') #3 /var/www/html/phpservermon/src/psm/Router.php(54): psm\Router->buildServiceContainer() #4 /var/www/html/phpservermon/src/bootstrap.php(66): psm\Router->__construct() #5 /var/www/html/phpservermon/index.php(28): require('/var/www/html/p...') #6 {main} thrown in /var/www/html/phpservermon/vendor/symfony/config/Util/XmlUtils.php on line 52

I tried going to the files the error points to and tried figuring out what is wrong, but can't.

I'm using Ubuntu 18.04 and php7.2 also I used this website for the phpservermonitor setup

https://www.itzgeek.com/how-tos/linux/ubuntu-how-tos/install-php-server-monitor-on-ubuntu-15-04-centos-7-fedora-22.html

I've used this site to install phpservermon before and never got this error.

Someone please help me how to troubleshoot this or fix it.

PS: any info you could use just ask.

0

As said in the requirements, PHP Server Monitor requires PHP 5.3.7+

PHP 7.2 is way higher than 5.3, this "PHP Server Monitor" seems to be not compatible with 7.2.

You can try to install PHP 5.6, i.e. thanks to sury.org packages, using this PPA: https://launchpad.net/~ondrej/+archive/ubuntu/php

But if you're looking for good, web-based monitoring tool, then you should rather take a look at netdata instead.

  • I'm only looking for the database, since I'm making my own platform. Also this might be it since last time I had both php7.2 and php5.3 in my machine – PAPARIPA May 2 at 8:47
  • The errors diminished quite allot, but I still got the first error back Fatal error: Class 'DOMDocument' not found in /var/www/html/phpservermon/vendor/symfony/config/Util/XmlUtils.php:52 – PAPARIPA May 2 at 9:04
  • For anyone with a similar problem: This fixed most of the errors (most being the keyword), if you continue to get the same error as me I've created this question: askubuntu.com/questions/1139929/class-domdocument-not-found – PAPARIPA May 2 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.